I am using file beat to send my log file to the kibana but within my table I am seeing these two fields and I dont want them to be seen until I am facing with a parse error.

my yml file:


# Each - is a prospector. Most options can be set at the prospector level, so
# you can use different prospectors for various configurations.
# Below are the prospector specific configurations.

- type: log

  # Change to true to enable this prospector configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
    #- /var/log/*.log
    - C:\Users\erdogan.alper\Desktop\log\*.json
  json.message_key: json
  json.keys_under_root: true
  json.add_error_key: true

  multiline.pattern: '^'
  multiline.negate: true
  multiline.match: after

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.