Error running logstash-input-couchdb_changes plugin


(imad) #1

Hi,

I am having problem running this plugin. I downloaded logstash and logstash-input-couchdb_changes plugin, unzipped those and then followed 1st two steps in the sections below. I am running windows 7. I didn't install any ruby packages.. Don't know if I need to install any ruby packages or not? Please help.

Run in a local Logstash clone

Edit Logstash Gemfile and add the local plugin path, for example:

gem "logstash-filter-awesome", :path => "/your/local/logstash-filter-awesome"

Install plugin

bin/plugin install --no-verify

But I am getting this error:
E:/Softwares/Web Related\logstash-1.5.3\logstash-1.5.3\bin>plugin install --no-verify
io/console not supported; tty will not be manipulated
Installing...
NameError: undefined local variable or method `path' for #LogStash::DSL:0x24fabd0f
(eval) at (eval):122
instance_eval at org/jruby/RubyBasicObject.java:1541
parse at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/lib/pluginmanager/gemfile.rb:156
load at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/lib/pluginmanager/gemfile.rb:18
gemfile at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/lib/pluginmanager/command.rb:3
install_gems_list! at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/lib/pluginmanager/install.rb:96
execute at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/lib/pluginmanager/install.rb:28
run at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
execute at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
run at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
run at E:/Softwares/Web Related/logstash-1.5.3/logstash-1.5.3/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
(root) at E:\Softwares\Web Related\logstash-1.5.3\logstash-1.5.3\lib\pluginmanager\main.rb:36


(imad) #2
      I tried with logstash version 1.5.2. I tested logstash with

"logstash -e 'input { stdin { } } output { stdout {} }'" and it worked
except that I got message "io/console not supported; tty will not be
manipulated" (don't know whats this for) but when I tried to install
plugin it failed with error:

io/console not supported; tty will not be manipulated

Installing...

Plugin not found, aborting

ERROR: Installation Aborted, message: Could not find gem 'logstash-input-couchdb

_changes-master (>= 0) java' in source at E:/Softwares/Web Related/logstash-1.5.

2/logstash-input-couchdb_changes-master.

Source does not contain any versions of 'logstash-input-couchdb_changes-master (

= 0) java'

Is there anything Im missing? Please help


(imad) #3

solution is to just run the following to install couchdb plugin.

bin/plugin install logstash-input-couchdb_changes


(system) #4