Error - The signal HUP is in use by the JVM and will not work correctly on this platform

I am trying command in LogStash:

logstash -e 'input { stdin { } } output { elasticsearch { host => localhost } }'

Getting error like -

io/console not supported; tty will not be manipulated
The signal HUP is in use by the JVM and will not work correctly on this platform.

Please help me....


Any one faced same error???

Any solution????

Please help

What OS are you on? What version of LS?

I am using Windows 10 and LS 2.3.1

I am having the same issue and I am also on Windows 10 and LS 2.3.1.

I'm facing similar issue. Does anyone have a fix for this?

I am facing the same issue. I am running on windows 10 with cygwin terminal and LS 2.3.1. Can someone provide a proper solution to this problem? Really stuck :frowning:

tried restarting my system, but no luck. not much help on google too.
were you able to resolve this?


FYI - i restarted couple of times and reverted back to the old config file that was working and now logstash is processing.
no idea what HUP error has to do with config file change. but glad its up now.

Hi @Amit2015,

Were you able to overcome this challenge? I'm having the same problem with Windows 7 & LS 2.3.2


I had this problem, putting the full path the the config file solved it.

I have restarted my machine and used a very basic config file which run well on 2.2.2. Is version 2.3.2 even usable at all?

If yes. How can it be used?

I had the same issue on windows 7. Then i had executed the command with all small case letters and it worked.

Neither of these messages is fatal to Logstash. If you are having configuration errors, they are not what is generating these messages. The HUP message is actually from JRuby.