Error using Endpoint Security in Linux

Hi all
I was testing Elastic Agent with Endpoint Security policy.
I thought only malware protection doesn't work in linux, but I get this error when I try to use Endpoint Security.

I also tried Endpoint Security policy with malware protection disabled, but same error appears.
I wonder what's the problem...

Thanks in advance!

Hi @roh. Thanks for trying out Endpoint Security!

What Linux distribution and version are you using, and what architecture?

Sorry for the late reply...
Here's Linux distribution, version and architecture

Running Endpoint under WSL is not supported. The issue you're encountering is Endpoint fails to install it's systemd service, it seems because WSL doesn't have "real" support for systemd.

Is there a reason you're installing under WSL rather than on the Windows "host" or on a standalone Linux machine? We're of course always interested to understand user needs and support them the best we can.

Thanks for the reply, @ferullo
The reason why I tried to install under WSL is not that special.
I had to test on Linux and the easy way I knew was using WSL.
Don't have standalone Linux machine either :frowning:
Then will using Linux VM work?

Install virtualbox and go

Yes, a Linux VM will work.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.