Error when trying to implement jqeury for siteseaerch

Hi.
im am following this official guide for jQuery Plugin Guide:

when loading the needed scripts i get an error:

Uncaught TypeError: Cannot read property 'msie' of undefined
at jquery.ba-hashchange.min.js:9

is this guide out of date? has anyone tried to use it?

thanks

so.. anyone?

@elitzur_e I'm not familiar with this guide. Will run through it later today and see if I can give you some help.

@elitzur_e Hello, I apologize for the delay. I just ran through it myself. It was unfortunately out of date. I am in the process of updating that documentation.

The reason you are seeing those errors is because the library no longer relies on "jquery.ba-hashchange.min.js". If you simply remove that from the example code, your error should be resolved.

Hi there ~

@JasonStoltz updated the jQuery guide -- it should not lead you down a rabbit hole this time. :slight_smile:

Enjoy the day,

Kellen

Thanks for that. Ill check.
Makes me wonder why am i the only one using this guide. Is there a different newer alt? ...

Good day ~

jQuery is a reliable technology, but it seems many people are looking at more "modern" frameworks.

We've recently released Search UI. It's a JavaScript library; if you're interested in React, it's a great way to build robust and customizable search experiences with minimal effort.

It has a Site Search connector so there's no extra configuration required outside the UI.

Enjoy the week,

Kellen

well i looked in to it.

first it seemed to be still in beta (no final release out - 0.12 is out) and i need something more production worthy.

second, i tried using it:

it seems to have little documentations about using it with site search connector and even less with site search with crawler base engine.

so far the application crashes when trying to connect it to a site search (with crawler base engine)

unless I'm missing something? :slight_smile:

You're right -- the documentation is sparse. To start, we've focused on making the experience with App Search more tidy. Site Search will follow, once we have a better place to put documentation other than the README.

Do you have any logs you can show which show the crash? Or configuration snippets?

hi,
i made a new topic about it just to stay keep things in order:


can you take a look please?

thanks :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.