Error while injecting data from sqlite3 database

I am trying to create index for sqlite3 database but I am getting error saying

Plugin: <LogStash::Inputs::Sqlite path=>"/home/kagamee/liveshield/api-sqlite/Yogesh/SimpleSocketIO/db/networkdata.db", id=>"c46d1a331470c1776c51a4622fe08bc2a6b6ab59f5bd4face2a0bb0e83b5cb3b", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_d5107a01-7507-48f4-9ba0-54919f96af0b", enable_metric=>true, charset=>"UTF-8">, batch=>5>
Error: Missing Converter handling for full class name=org.jruby.gen.RubyObject30, simple name=RubyObject30```
My conf file looks like:
 ```input {
 sqlite {
 path=> "home//db/networkdata.db"
output {
 stdout {
 codec => rubydebug
I've already installed sqlite3 plugin still unable to solve the error.

Thanks in Advance

”Missing Converter‟ usually means that you are trying to load a database column with a datatype that is not supported, Logstash doesn't know how to represent the data with a Logstash data type.

But the fields in my database are only integers and characters

Even if there are some fields which might not be able to converted can I use mutate to change there data types them?

If that error occurs within the input plugin you don't ever get an object with a field that you could convert because the code that would create your event object crashes. It seems like you are not alone, but I could not find a solution:

Even though I tried with the example given on "" but getting the same error.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.