Errors after updating plugins in 6.8

I'm using Logstash 6.8 and am using some updated versions of plugins which have been updated with the command:

logstash-plugin update logstash-filter-kv logstash-input-s3 logstash-filter-json

This has worked fine for a long time but since roughly two weeks ago I am now getting this error when trying to run logstash after updating plugins:

[2020-07-15T15:09:24,442][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<NameError: uninitialized constant LibC::FFI>, :backtrace=>["org/jruby/ `const_missing'", "/usr/share/logstash/logstash-core/lib/logstash/util/prctl.rb:4:in `<module:LibC>'", "/usr/share/logstash/logstash-core/lib/logstash/util/prctl.rb:2:in `<main>'", "org/jruby/ `require'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'", "/usr/share/logstash/logstash-core/lib/logstash/util.rb:21:in `set_thread_name'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:306:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:237:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/opt/logstash/lib/bootstrap/environment.rb:73:in `<main>'"]}
[2020-07-15T15:09:24,446][ERROR][org.logstash.Logstash    ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

It doesn't seem to be affected by which plugins I update, just updating any will produce this error when I run logstash after updating. Any ideas why and how to fix?

I've tried this on 6.8.2 and 6.8.10 with similar results.

Looks like this is actually a problem with how I'm launching Logstash, and may not be a problem with Logstash itself.

I'm running it through logstash-filter-verifier. I have raised an issue here with a reproduceable test case:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.