Exclude_Files not working in Filebeat

Hi there!
I have been trying to exclude a file from a directory, here's the dir structure which I have-
var/logs/domain-a/HSC1/HSC1/logger.log
var/logs/domain-b/HSC2/HSC2/logger.log
var/logs/domain-c/HSC3/HSC3/logger.log
var/logs/domain-d/HSC4/HSC4/logger.log

I want to include the 1st 3 log files (domain-a, b, and c) but not the domain-d file.
The path that I have written in the filebeat.yml file is -

filebeat.inputs:
- type: log
  enabled: true
  paths:
    - /var/logs/*/*/*/logger.log
  exclude_files: 
    -  '/var/logs/domain-d/HSC4/HSC4/logger.log'

Is the above config correct? And is there any way I could do this by exclude_files or some other method? Thanks