Exclude lines starting hash not working


(Bara Mustafa) #1

I'm running filebeat on Windows (v1.2.1) and trying to get it to exclude lines starting with hashes. I believe I have configured it correctly but it still seems to send through lines beginning with hash to LogStash. I've tried with: ['^\#'] and ['^#'] but both fail to work. Is there something obvious I'm doing wrong?

filebeat:
  prospectors:
    -
      paths:
        - C:\inetpub\logs\LogFiles\W3SVC1\*.LOG
      input_type: log
      exclude_lines: ['^\#']
  registry_file: "C:/ProgramData/filebeat/registry"
output:
  logstash:
    hosts: ["logstash-server.test.local:5044"]

(ruflin) #2

Could you try using "double quotes" instead of single quotes?


(system) #3