Exiting: No paths were defined for input accessing config


(Vijay) #1

Hello,

Here is the problem.

When I run filebeat command on command prompt, it starts writing to the logs instantly. However, if I execute "filebeat modules enable system" command and then run "filebeat" command, it gives me an error
"Exiting: No paths were defined for input accessing config" and it stops writing to the log file in the logs directory.

I have set the configuration withing filebeat.yml file as follows:

#=========================== Filebeat inputs =============================
filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.

- type: log

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    #- /var/log/*.log
    - D:\filebeat\logs\*


#============================= Filebeat modules ===============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 3

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

Because of this issue, I see no logs when I login using Kibana URL.

PS - I execute the steps for filebeat as per the instructions mentioned at https://www.elastic.co/solutions/logging


(ruflin) #2

It sounds like something is wrong with the paths? How did you exactly install Filebeat? What OS are you on?


(Vijay) #3

I just extracted the zip file contents into a folder and tried the filebeat commands via command prompt.
I am on Windows 7. I am using filebeat 6.3.1.


(ruflin) #4

Did you run the command from inside the Filebeat directory or outside? Can you share the exact command you did run?


(Vijay) #5

I ran it from within the filebeat directory. The command is

filebeat modules enable system.

After I run this command if I try running "filebeat" command, I get the error. If I disable the system module using "filebeat modules disable system" and then run "filebeat" command, the logs are written within the logs directory.


(ruflin) #6

I reformatted you config above as I was hoping it would show the problem. It indicated that you haven't configured any paths but they all seem to be there. I assume the config file you posted above is in your filebeat directory?

Could you run the beat with -e -d "*" and share the output here?


(Vijay) #7

The output is

D:\fb>filebeat -e -d ""
2018-07-17T13:30:55.291+0530 INFO instance/beat.go:492 Home path: [D:\f
b] Config path: [D:\fb] Data path: [D:\fb\data] Logs path: [D:\fb\logs]
2018-07-17T13:30:55.292+0530 DEBUG [beat] instance/beat.go:519 Beat met
adata path: D:\fb\data\meta.json
2018-07-17T13:30:55.293+0530 INFO instance/beat.go:499 Beat UUID: 963cb
2f5-f182-40bf-9e99-8e1026094e69
2018-07-17T13:30:55.293+0530 INFO [beat] instance/beat.go:716 Beat inf
o {"system_info": {"beat": {"path": {"config": "D:\fb", "data": "D:\fb\
data", "home": "D:\fb", "logs": "D:\fb\logs"}, "type": "filebeat", "uuid": "9
63cb2f5-f182-40bf-9e99-8e1026094e69"}}}
2018-07-17T13:30:55.294+0530 INFO [beat] instance/beat.go:725 Build in
fo {"system_info": {"build": {"commit": "ed42bb85e72ae58cc09748dc1825159713
e0ffd4", "libbeat": "6.3.1", "time": "2018-06-29T21:09:04.000Z", "version": "6.3
.1"}}}
2018-07-17T13:30:55.294+0530 INFO [beat] instance/beat.go:728 Go runti
me info {"system_info": {"go": {"os":"windows","arch":"amd64","max_procs":4,"ver
sion":"go1.9.4"}}}
2018-07-17T13:30:55.303+0530 INFO [beat] instance/beat.go:732 Host inf
o {"system_info": {"host": {"architecture":"x86_64","boot_time":"2018-07-1
7T11:19:01.69+05:30","hostname":"FSGLPTIN-372","ips":["169.254.171.124/16","169.
254.232.205/16","172.20.40.242/22","169.254.251.191/16","::1/128","127.0.0.1/8"]
,"kernel_version":"6.1.7601.24168 (win7sp1_ldr.180608-0600)","mac_addresses":["4
2:a3:cc:07:4d:2f","42:a3:cc:07:4d:2e","40:a3:cc:07:4d:2e","8c:16:45:18:8c:70"],"
os":{"family":"windows","platform":"windows","name":"Windows 7 Professional","ve
rsion":"6.1","major":1,"minor":0,"patch":0,"build":"7601.24180"},"timezone":"IST
","timezone_offset_sec":19800,"id":"87ae77ee-f928-46da-82ac-625d8d51ed3a"}}}
2018-07-17T13:30:55.304+0530 INFO instance/beat.go:225 Setup Beat: file
beat; Version: 6.3.1
2018-07-17T13:30:55.304+0530 DEBUG [beat] instance/beat.go:242 Initiali
zing output plugins
2018-07-17T13:30:55.305+0530 DEBUG [processors] processors/processor.go:
49 Processors:
2018-07-17T13:30:55.305+0530 INFO elasticsearch/client.go:145 Elastics
earch url: http://localhost:9200
2018-07-17T13:30:55.307+0530 DEBUG [publish] pipeline/consumer.go:120
start pipeline event consumer
2018-07-17T13:30:55.308+0530 INFO pipeline/module.go:81 Beat name: FSGLP
TIN-372
2018-07-17T13:30:55.309+0530 INFO instance/beat.go:315 filebeat start r
unning.
2018-07-17T13:30:55.309+0530 INFO [monitoring] log/log.go:97 Starting
metrics logging every 30s
2018-07-17T13:30:55.309+0530 DEBUG [service] service/service_windows.
go:51 Windows is interactive: true
2018-07-17T13:30:55.309+0530 DEBUG [registrar] registrar/registrar.go:9
6 Registry file set to: D:\fb\data\registry
2018-07-17T13:30:55.311+0530 INFO registrar/registrar.go:116 Loading
registrar data from D:\fb\data\registry
2018-07-17T13:30:55.311+0530 INFO registrar/registrar.go:127 States L
oaded from registrar: 0
2018-07-17T13:30:55.312+0530 INFO crawler/crawler.go:48 Loading Inputs:
1
2018-07-17T13:30:55.312+0530 DEBUG [processors] processors/processor.go:
49 Processors:
2018-07-17T13:30:55.312+0530 DEBUG [registrar] registrar/registrar.go:1
58 Starting Registrar
2018-07-17T13:30:55.313+0530 DEBUG [input] log/config.go:178 recursiv
e glob enabled
2018-07-17T13:30:55.314+0530 DEBUG [input] log/input.go:122 exclude_
files: []. Number of stats: 0
2018-07-17T13:30:55.314+0530 DEBUG [input] log/input.go:143 input wi
th previous states loaded: 0
2018-07-17T13:30:55.314+0530 INFO log/input.go:113 Configured paths
: [D:\fb\logs*.log]
2018-07-17T13:30:55.315+0530 INFO input/input.go:88 Starting input o
f type: log; ID: 15224572257225558479
2018-07-17T13:30:55.315+0530 DEBUG [input] log/input.go:149 Start ne
xt scan
2018-07-17T13:30:55.315+0530 DEBUG [cfgfile] cfgfile/reload.go:90
Checking module configs from: D:\fb/modules.d/
.yml
2018-07-17T13:30:55.316+0530 DEBUG [input] log/input.go:170 input st
ates cleaned up. Before: 0, After: 0, Pending: 0
2018-07-17T13:30:55.316+0530 DEBUG [cfgfile] cfgfile/cfgfile.go:143
Load config from file: D:\fb\modules.d\system.yml
2018-07-17T13:30:55.318+0530 DEBUG [cfgfile] cfgfile/reload.go:104
Number of module configs found: 1
2018-07-17T13:30:55.321+0530 DEBUG [processors] processors/processor.go:
49 Processors:
2018-07-17T13:30:55.322+0530 ERROR fileset/factory.go:72 Error creating i
nput: No paths were defined for input accessing config
2018-07-17T13:30:55.322+0530 INFO crawler/crawler.go:109 Stopping Crawler

2018-07-17T13:30:55.323+0530 INFO crawler/crawler.go:119 Stopping 1 input
s
2018-07-17T13:30:55.323+0530 INFO input/input.go:122 input ticker sto
pped
2018-07-17T13:30:55.323+0530 INFO input/input.go:139 Stopping Input:
15224572257225558479
2018-07-17T13:30:55.324+0530 DEBUG [publish] pipeline/client.go:131
client: closing acker
2018-07-17T13:30:55.324+0530 DEBUG [publish] pipeline/client.go:133
client: done closing acker
2018-07-17T13:30:55.325+0530 DEBUG [publish] pipeline/client.go:137
client: cancelled 0 events
2018-07-17T13:30:55.325+0530 INFO crawler/crawler.go:135 Crawler stopped
2018-07-17T13:30:55.326+0530 INFO registrar/registrar.go:247 Stopping
Registrar
2018-07-17T13:30:55.326+0530 DEBUG [publish] pipeline/client.go:131
client: closing acker
2018-07-17T13:30:55.327+0530 DEBUG [publish] pipeline/client.go:133
client: done closing acker
2018-07-17T13:30:55.326+0530 INFO registrar/registrar.go:173 Ending R
egistrar
2018-07-17T13:30:55.327+0530 DEBUG [publish] pipeline/client.go:137
client: cancelled 0 events
2018-07-17T13:30:55.328+0530 DEBUG [registrar] registrar/registrar.go:2
91 Write registry file: D:\fb\data\registry
2018-07-17T13:30:55.332+0530 DEBUG [registrar] registrar/registrar.go:2
84 Registry file updated. 0 states written.


(Vijay) #8

2018-07-17T13:30:55.390+0530 INFO [monitoring] log/log.go:132 Total no
n-zero metrics {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":62,
"time":{"ms":62}},"total":{"ticks":108,"time":{"ms":108},"value":108},"user":{"t
icks":46,"time":{"ms":46}}},"info":{"ephemeral_id":"efef3bce-25ab-41f7-a898-e90b
65f0d29d","uptime":{"ms":96}},"memstats":{"gc_next":4194304,"memory_alloc":16754
40,"memory_total":3414520,"rss":17305600}},"filebeat":{"harvester":{"open_files"
:0,"running":0}},"libbeat":{"config":{"module":{"running":0}},"output":{"type":"
elasticsearch"},"pipeline":{"clients":0,"events":{"active":0}}},"registrar":{"st
ates":{"current":0},"writes":{"success":1,"total":1}},"system":{"cpu":{"cores":4
}}}}}
2018-07-17T13:30:55.391+0530 INFO [monitoring] log/log.go:133 Uptime:
155ms
2018-07-17T13:30:55.391+0530 INFO [monitoring] log/log.go:110 Stopping
metrics logging.
2018-07-17T13:30:55.392+0530 INFO instance/beat.go:321 filebeat stopped
.
2018-07-17T13:30:55.393+0530 ERROR instance/beat.go:691 Exiting: No path
s were defined for input accessing config
Exiting: No paths were defined for input accessing config

D:\fb>


(ruflin) #9

Could you try to use - 'D:\filebeat\logs\*' as you path config? It seems for some reason Filebeat ignores the part under paths. Could you also remove the commented out line just to be sure id does not have any affect?

What do you get if you run ls D:\filebeat\logs\?

I see you also have the module loading enabled. Do you need it?


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.