External configuration and 'type'


#1

Hi,

When I set up an external config file with:

- type: log

The index gets populated with "input.type" and "prospector.type". (whole stack is updated to 6.4.2)
If I change that to:

- input.type: log

None of the above are indexed. I'd like to avoid duplication but if I can't I rather have none of the fields.
Any suggestion?

Thanks!


(Steffen Siering) #2

There is no setting named input.type. The field input.type is new and beats still report prospector.type for backwards compatibility reasons. The field prospector.type will be removed in the future. You can use the drop_fields processor to remove prospector sub-documented.


#3

When I tried 'drop_fields' with adding prospector.type, it didn't work, but with prospectorit works as expected.

Thank you!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.