Facing delay in logs

Hi Team,

We are not getting the real time logs in kibana.

1.We have tried restarting the filebeat,logstash and elasticsearch.
2.We have changed the communication port between logstash and filebeat. Eventhough Connectivity is there between logstash and filebeat ,logs are not flowing in properly.
3.We have tried updating the logstash input beat plugin and increased client_inactivity_timeout to 900s in logstash config.
4.Tried Implementing the new filebeat version.
5.We have checked for disk and memory usage,we have enough memory space.

can you please help us to resolve this issue?


Could you share your configurations, especially filebeat.yml? There are a lot of possible configuration problems that could keep logs from getting through. Also, can you tell where in the links the data is being lost? It sounds like you're using logstash, so can you tell if logstash is receiving data and failing to send it to elasticsearch, or if filebeat never sends it to logstash at all?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.