Facing issue while starting multiple instance of logstash


(Sukeerthi Bj) #1

Hi,

I created a separate folder for new instance of logstash as mentioned in below link

but getting logstash status as failed

systemctl status logstash-suk.service
● logstash-suk.service - logstash-suk
Loaded: loaded (/etc/systemd/system/logstash-suk.service; disabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Thu 2017-09-14 14:35:18 IST; 14min ago
Main PID: 11874 (code=exited, status=217/USER)
[root@bmvt logstash]# cd /etc/systemd/system/


(Magnus Bäck) #2

And what's the contents of the unit file for this service?


(Sukeerthi Bj) #3

## > ################################################################################
## > # These settings are ONLY used by $LS_HOME/bin/system-install to create a custom
**## > # startup script for Logstash. It sh
ould automat

Summary

This text will be hidden

ically use the init system**
## > # (systemd, upstart, sysv, etc.) that your Linux distribution uses.
## > #
## > # After changing anything here, you need to re-run $LS_HOME/bin/system-install
## > # as root to push the changes to the init script.
## > ################################################################################
**## > **
## > # Override Java location
## > JAVACMD=/usr/bin/java
**## > **
## > # Set a home directory
## > LS_HOME=/usr/share/logstash
**## > **
## > # logstash settings directory, the path which contains logstash.yml
## > LS_SETTINGS_DIR=/home/build/sukeerthi/logstash
**## > **
## > # Arguments to pass to logstash
## > LS_OPTS="--path.settings ${LS_SETTINGS_DIR}"
**## > **
## > # Arguments to pass to java
## > LS_JAVA_OPTS=""
**## > **
## > # pidfiles aren't used the same way for upstart and systemd; this is for sysv users.
## > LS_PIDFILE=/var/run/logstash.pid
**## > **
## > # user and group id to be invoked as
## > LS_USER=logstash
## > LS_GROUP=logstash
**## > **
## > # Enable GC logging by uncommenting the appropriate lines in the GC logging
## > # section in jvm.options
## > LS_GC_LOG_FILE=/var/log/logstash/gc.log
**## > **
## > # Open file limit
## > LS_OPEN_FILES=16384
**## > **
## > # Nice level
## > LS_NICE=19
**## > **
## > # Change these to have the init script named and described differently
## > # This is useful when running multiple instances of Logstash on the same
## > # physical box or vm
## > SERVICE_NAME="logstash-suk"
## > SERVICE_DESCRIPTION="logstash-suk"
**## > **
## > # If you need to run a command or script before launching Logstash, put it
## > # between the lines beginning with read and EOM, and uncomment those lines.
## > ###
## > ## read -r -d '' PRESTART << EOM
## > ## EOM


(Magnus Bäck) #4

Um, what? That's not a systemd unit file.


(Sukeerthi Bj) #5

[Manager]
#LogLevel=info
#LogTarget=journal-or-kmsg
#LogColor=yes
#LogLocation=no
#DumpCore=yes
#CrashShell=no
#ShowStatus=yes
#CrashChVT=1
#CPUAffinity=1 2
#JoinControllers=cpu,cpuacct net_cls,net_prio
#RuntimeWatchdogSec=0
#ShutdownWatchdogSec=10min
#CapabilityBoundingSet=
#SystemCallArchitectures=
#TimerSlackNSec=
#DefaultTimerAccuracySec=1min
#DefaultStandardOutput=journal
#DefaultStandardError=inherit
#DefaultTimeoutStartSec=90s
#DefaultTimeoutStopSec=90s
#DefaultRestartSec=100ms
#DefaultStartLimitInterval=10s
#DefaultStartLimitBurst=5
#DefaultEnvironment=
#DefaultCPUAccounting=no
#DefaultBlockIOAccounting=no
#DefaultMemoryAccounting=no
#DefaultLimitCPU=
#DefaultLimitFSIZE=
#DefaultLimitDATA=
#DefaultLimitSTACK=
#DefaultLimitCORE=
#DefaultLimitRSS=
#DefaultLimitNOFILE=
#DefaultLimitAS=
#DefaultLimitNPROC=
#DefaultLimitMEMLOCK=
#DefaultLimitLOCKS=
#DefaultLimitSIGPENDING=
#DefaultLimitMSGQUEUE=
#DefaultLimitNICE=
#DefaultLimitRTPRIO=
#DefaultLimitRTTIME=


(Magnus Bäck) #6

That's more like it, but everything's commented out so I don't see how it could possibly do something useful.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.