Failed to execute logstash.javapipeline ] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<ArgumentError: The "sincedb_path" argument must point to a file, received a directory: "C:/dev/null">

Config File:

input{
file{
path =>"C:\logstash-7.2.0\config\cars.csv"
start_position => "beginning"
sincedb_path => "C:/dev/null"
}
}
filter{
csv{
separator=>","
columns=> ["maker", "model", "mileage", "manufacture_year", "engine_displacement", "engine_power", "body_type", "color_slug", "stk_year", "transmission", "door_count", "seat_count", "fuel_type", "date_created", "date_last_seen", "price_eur"]
}
mutate{convert => ["mileage", "integer"]}
mutate{convert => ["price_eur", "float"]}
mutate{convert => ["engine_power", "integer"]}
mutate{convert => ["door_count", "integer"]}
mutate{convert => ["seat_count", "integer"]}
}
output {
elasticsearch{
hosts => ["localhost:9200"]
index => ["cars"]
document_type => "sold_cars"
}
stdout {}
}

Error in Windows CMD:

C:\logstash-7.2.0\bin>logstash.bat -f C:\Users\VikrantMittal\Desktop\Data\Logstash_cars.config
Thread.exclusive is deprecated, use Thread::Mutex
Sending Logstash logs to C:/logstash-7.2.0/logs which is now configured via log4j2.properties
[2019-08-01T13:21:23,859][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-08-01T13:21:23,884][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.2.0"}
[2019-08-01T13:21:31,461][WARN ][logstash.outputs.elasticsearch] You are using a deprecated config setting "document_type" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Document types are being deprecated in Elasticsearch 6.0, and removed entirely in 7.0. You should avoid this feature If you have any questions about this, please visit the #logstash channel on freenode irc. {:name=>"document_type", :plugin=><LogStash::Outputs::ElasticSearch index=>"cars", id=>"5925a7b6c4d4848492b1e1022f0f6e414241546eb04128795fc22767b3eea416", hosts=>[//localhost:9200], document_type=>"sold_cars", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_54963c73-b2a1-4e33-859c-3a5bd3d5d9ac", enable_metric=>true, charset=>"UTF-8">, workers=>1, manage_template=>true, template_name=>"logstash", template_overwrite=>false, doc_as_upsert=>false, script_type=>"inline", script_lang=>"painless", script_var_name=>"event", scripted_upsert=>false, retry_initial_interval=>2, retry_max_interval=>64, retry_on_conflict=>1, ilm_enabled=>"auto", ilm_rollover_alias=>"logstash", ilm_pattern=>"{now/d}-000001", ilm_policy=>"logstash-policy", action=>"index", ssl_certificate_verification=>true, sniffing=>false, sniffing_delay=>5, timeout=>60, pool_max=>1000, pool_max_per_route=>100, resurrect_delay=>5, validate_after_inactivity=>10000, http_compression=>false>}
[2019-08-01T13:21:32,359][INFO ][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=>{:removed=>, :added=>[http://localhost:9200/]}}
[2019-08-01T13:21:32,682][WARN ][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=>"http://localhost:9200/"}
[2019-08-01T13:21:32,741][INFO ][logstash.outputs.elasticsearch] ES Output version determined {:es_version=>7}
[2019-08-01T13:21:32,744][WARN ][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the type event field won't be used to determine the document _type {:es_version=>7}
[2019-08-01T13:21:32,768][INFO ][logstash.outputs.elasticsearch] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//localhost:9200"]}
[2019-08-01T13:21:32,869][INFO ][logstash.outputs.elasticsearch] Using default mapping template
[2019-08-01T13:21:32,938][WARN ][org.logstash.instrument.metrics.gauge.LazyDelegatingGauge] A gauge metric of an unknown type (org.jruby.specialized.RubyArrayOneObject) has been create for key: cluster_uuids. This may result in invalid serialization. It is recommended to log an issue to the responsible developer/development team.
[2019-08-01T13:21:32,943][INFO ][logstash.javapipeline ] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>500, :thread=>"#<Thread:0x42c11 run>"}
[2019-08-01T13:21:32,945][INFO ][logstash.outputs.elasticsearch] Attempting to install template {:manage_template=>{"index_patterns"=>"logstash-", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s", "number_of_shards"=>1}, "mappings"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}
[2019-08-01T13:21:35,828][ERROR][logstash.javapipeline ] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<ArgumentError: The "sincedb_path" argument must point to a file, received a directory: "C:/dev/null">, :backtrace=>["C:/logstash-7.2.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.10/lib/logstash/inputs/file.rb:280:in register'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:192:inblock in register_plugins'", "org/jruby/RubyArray.java:1792:in each'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:191:inregister_plugins'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:292:in start_inputs'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:248:instart_workers'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:146:in run'", "C:/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:105:inblock in start'"], :thread=>"#<Thread:0x42c11 run>"}
[2019-08-01T13:21:35,881][ERROR][logstash.agent ] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create, action_result: false", :backtrace=>nil}
[2019-08-01T13:21:36,238][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2019-08-01T13:21:41,194][INFO ][logstash.runner ] Logstash shut down.

On Windows, if you do not want logstash to persists the in-memory sincedb to disk then set

 sincedb_path => "NUL"

Also, do not use backslash in path option of a file input, use forward slash.