I've installed Filebeat on my mac with Homebrew; in the config folder i don't find the Field.yml .
Could you helm me ?

Which version of Filebeat did you install? I remember it was missing in some older versions.

1 Like

a last 6.2.1

Hm, I just looked at the formula and it seems it's still not copied or this went lost somehow :frowning:

@tylerjl Perhaps you know more here?

Hey, it does indeed look like some Beats are missing the fields.yml file. I've submitted a PR to the homebrew project to get things fixed for all Beats formulae.

Thank you very much.Will I install again Filebeat to get Field.yml?

@gongon once the changes are merged by the Homebrew project, you should be able to brew reinstall filebeat to get the necessary yaml files.

OK Thank you very much

Hi! I have the same problem with the dashboard.Is there a relationship between the lack of the indextemplate?

It seems the modules directories are copied to everything should work here. Can you share the error here?

Here a copy of the error
Last login: Wed Mar 14 09:10:02 on console
I3893-2:~ gongon$ cd /usr/local/Cellar/filebeat/6.2.1
I3893-2:6.2.1 gongon$ filebeat setup --dashboards
Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/local/Cellar/filebeat/6.2.1/kibana: No directory /usr/local/Cellar/filebeat/6.2.1/kibana/6

I can't run the module (Apache), I can't load the indextemplate of Filebeat

That doesn't look good. @tylerjl Can you also check that one?

Yep, the formulae aren't installing the kibana config directory at the moment. I'll look at fixing it and update.

OK.Thank you very much

@gongon and @ruflin the PR has been merged, so all of the beats formulae in homebrew should be much more consistent and able to install dashboards/enable modules/etc. If you update homebrew and install the updated beat, things should look better. Please let us know if you encounter any additional problems.

Great! Thank you very much.
Sure :smile: I am going to follow your advice. I am keeping informing you.

@tylerjl Thanks for making this happen :elasticheart:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.