File input adds escaping


(Sapir) #1

I would like to disable escaping when receiving events from a file.
For instance, here is the event (input is a file):
a="hello" b="world"
This is the output:
a=\"hello\" b=\"world\"\r"

While using other inputs such as tcp, udp, no escaping is being added.

How to disable and remove the escaping? Is there a generic solution for that? codec/plugins and not a fix in the filter itself?

I prefer not using: msg.gsub! ('"', '"') Thanks:)


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.