Filebeat 5.6.16 modifies logstash URL:PORT in runtime

I am running filebeat 5.6.16 on Ubuntu 18.04 x64

Here is my filebeat output section configuration:

hosts: [""]
bulk_max_size: 10000

When I start the filebeat i see that it can not ship log files to logstash, and see the following in debug mode:

2019/04/26 14:20:12.147710 sync.go:96: DBG 0 events out of 9996 events sent to logstash host Continue sending
2019/04/26 14:20:12.147726 sync.go:63: DBG close connection to logstash host
2019/04/26 14:20:12.147739 sync.go:105: ERR Failed to publish events (host:, caused by: EOF
2019/04/26 14:20:12.147752 single.go:91: INFO Error publishing events (retrying): EOF
2019/04/26 14:20:12.147763 sync.go:63: DBG close connection to logstash host
2019/04/26 14:20:12.147773 single.go:156: DBG send fail
2019/04/26 14:20:13.147995 sync.go:58: DBG connect to logstash host

Where does it take "10200" to add after port number and why it happens ?
The same behaviour inspected when running in docker.

Have to say that the same configuration worked fine with filebeat 1.3.1

Would be glad to get some assistance

I have found where was the problem. I was trying to send events to previous generation Elastic load balancer on AWS, and for some reason its behavior was non predictable. As a troubleshooting I have defined first all elastic ips of log aggregators to use them in round robin manner in filebeat configuration file, and it worked fine. Next step i have created new generation network load balancer to handle TCP:12904 traffic and it also worked fine.
Issue can be closed

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.