Filebeat cisco asa module source and destination IP showing reversed

Hi Team,

We are using the filebeat cisco asa module in filebeat to parse the data from cisco asa firewalls. One issues we noticed is the source IP and destination IP are actually showing as reversed when its parsed.

Filebeat Version 7.9.0 with cisco module enabled. Elasticsearch Version 7.9.0

Tried with Elasticsearch Version 7.10.1 also , its the same issue.


I tried a telnet to public IP on port 22 from our internal server 10.192.xxxxx

Now if i lookup in discovery for destination.ip : or destination.address : . it returns nothing.

But it i check the same IP as source.ip : or source.address : it gives me the output.

Please check the attached screenshot

Please advise.


Ajesh, could you please post your original logs? It looks like an issue with Beats.

Hello Marcin,

sorry for the delay , are you looking for cisco ASA Firewall logs? i will post it asap

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.