Filebeat connection refused to logstash

Hi

I'm a newbie, so please bare with me.
For couple of days I've been trying to figure out why I can't make logstash to listen to the port 5141.

At the conf.d I have

15-dns-syslog.conf

       beats {
       port => 5141
       type => "logs"
       tags => ["pihole","5141"]
       }
}

at filebeat.yml I have

filebeat.modules:
- module: logstash
filebeat.inputs:
- type: log
enabled: true
paths:
- /var/log/pihole.log
name: elk-hole
output.logstash:
enabled: true
hosts: ["127.0.0.1:5141"]

If I use netstat I can see that there is nothing listen on 5141. I don't know what is wrong.

Any help is welcome. thanks

Hey @Andre_Martins, welcome to discuss :slight_smile:

This seems to be a problem with the Logstash configuration, could you see any error in Logstash logs?

I think that the logstash configuration you are adding should be placed in the pipelines directory.