Filebeat error: fail to execute the HTTP GET request: Get "https://172.30.169.50:5000/api/status": x509: certificate signed by unknown authority

Hi Team,
Anyone had an idea why I am getting this error while setting up filebeat. Thanks so much.
</> Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to https://172.30.169.50:5000/api/status fails: fail to execute the HTTP GET request: Get "https://172.30.169.50:5000/api/status": x509: certificate signed by unknown authority. Response: </>

</>
I am only able to curl using http. and no luck with https
root@filelogs01-ph:~# curl -u elastic "http://172.30.169.50:9200/_cat/indices"
Enter host password for user 'elastic':
green open .security-7 SGZB30AyR62Tldu36eAOsA 1 0 60 0 276.8kb 276.8kb
green open .apm-custom-link rJpdqcMtQryvdDgOK9yFNA 1 0 0 0 226b 226b
green open .apm-agent-configuration 0fZldFi3R9y3Jfd_lgMMUw 1 0 0 0 226b 226b
green open .async-search Uc2q4OlRTPK12eRimZJnbw 1 0 12 4 105.7kb 105.7kb
green open .kibana_task_manager_7.17.4_001 mYgoqTxeRkyNClEpWyaCBQ 1 0 18 3367 2.5mb 2.5mb
green open .fleet-policies-7 VqPP2BZMQhurIqcsv8uaCw 1 0 2 0 11.3kb 11.3kb
green open .kibana_7.17.4_001 5glUOGE8TnG4GNoFYu0OZA 1 0 576 54 2.4mb 2.4mb
green open .tasks 7hTFpMWaS5CSEHQ_Asrn4Q 1 0 22 0 66.5kb 66.5kb
</>
kibana and elasticsearch server: 172.30.169.50
filebeat server: 172.30.169.51
</>
filebeat.inputs

  • type: syslog
    enabled: false
    paths:

    • /var/log/*.log
  • type: filestream
    enabled: false

    • /var/log/*.log

filebeat.config.modules:
enabled: false
path: ${path.config}/modules.d/*.yml
reload.enabled: true

setup.template.settings:
index.number_of_shards: 1

setup.kibana:
host: "https://172.30.169.50:5000"
ssl.verification_mode: "none"
username: "elastic"
password: "m4gN3s!@.123"

output.elasticsearch:
hosts: ["172.30.169.50:9200"]
ssl.verification_mode: "none"
username: "elastic"
password: "m4gN3s!@.123"

indices:

  • index: "sbx-%{+yyyy.MM.dd}"
    when.regexp:
    hostname: "^SBX-SS01.*"

processors:

  • add_host_metadata:
    when.not.contains.tags: forwarded
  • add_cloud_metadata: ~
  • add_docker_metadata: ~
  • add_kubernetes_metadata: ~

setup.ilm.overwrite: true
</>

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile: