Filebeat Error Failed to publish events write tcp

I am new to the whole Elasticsearch Topic and having some starter problems. I tried to search and find a solution on this topic in the Forum but couldnt find anything that could help me with it. I hope somebody can help me with this. Its seams to be a timeout problem with logstash but eather i am to stupid or inexperienced to implement the solution properly.

Filebeat 7.1
logstash 7.1

Oct 22 13:09:42 hdpkeyclo-prod1 filebeat[8963]: 2019-10-22T13:09:42.184Z        INFO        [monitoring]        log/log.go:144        Non-zero metrics in the last 30s        {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":440
Oct 22 13:09:13 hdpkeyclo-prod1 filebeat[8963]: 2019-10-22T13:09:13.723Z        INFO        pipeline/output.go:105        Connection to backoff(async(tcp://hdpbss-elk:5044)) established
Oct 22 13:09:13 hdpkeyclo-prod1 filebeat[8963]: 2019-10-22T13:09:13.721Z        INFO        pipeline/output.go:95        Connecting to backoff(async(tcp://hdpbss-elk:5044))
Oct 22 13:09:13 hdpkeyclo-prod1 filebeat[8963]: 2019-10-22T13:09:13.721Z        ERROR        pipeline/output.go:121        Failed to publish events: write tcp 10.88.49.8:55516->10.88.49.40:5044: write: connection reset by peer
Oct 22 13:09:12 hdpkeyclo-prod1 filebeat[8963]: 2019-10-22T13:09:12.311Z        ERROR        logstash/async.go:256        Failed to publish events caused by: write tcp 10.88.49.8:55516->10.88.49.40:5044: write: connection reset by peer



#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  enabled: true
  hosts: ["10.88.40.40:5044"]
  loadbalance: true
  timeout: 300
  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"


input {
  beats {
    client_inactivity_timeout => 600
    port => 5044
    tcp_keep_alive => true
  }
}
Closed because the Author of this Topic is an idiot.

input  {
  beats {
    port => 5044
    client_inactivity_timeout => 84600
  }
}

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.