Filebeat fails to start when output is set to file

I am quite new to filebeat and the ELK stack. After succesfully building a Filebeat, Elastic and Kibana stack indexing apache access logfiles, I wanted to use Filebeat to send output to a file for testing purposes. However, I keep running into an error. Filebeat starts and then immediately exits again because it is looking for elastic.

The relevant part of the logfile is below.

2020-02-20T16:19:40.794+0100	WARN	beater/filebeat.go:152	Filebeat is unable to load the Ingest Node pipelines for the configured modules because the Elasticsearch output is not configured/enabled. If you have already loaded the Ingest Node pipelines or are using Logstash pipelines, you can ignore this warning.
2020-02-20T16:19:40.794+0100	ERROR	instance/beat.go:916	Exiting: Index management requested but the Elasticsearch output is not configured/enabled

Below is the filebeat.yml that is used.

#=========================== Filebeat inputs =============================

- type: log
  enabled: true
    - C:\Some\folder\*

#============================= Filebeat modules ===============================

  path: C:\another\folder\*.yml
  reload.enabled: true

#------------------------------- File output -----------------------------------
  enabled: true
  path: 'C:\Yet\another\folder\'
  filename: filebeat

I have also configured an apache.yml

- module: apache
  # Access logs
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths: ['C:\Some\Folder\2\Access*']

Filebeat keeps asking for the elastic output to be configured, but only one output can be configured at a time.
Is there a some option I need to set?
I am using Elastic stack 7.5 on a windows 10 laptop

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.