Filebeat-god process does not create filebeat registry file as mentioned in the filebeat.yml config

I have specified the registry file as registry_file: .filebeat-registry and I have multiple file beat instances
and i want to have individual file beat registry for each of my file beat instances, this is the command I am

filebeat-god -r / -n -p /usr/xxx/filebeat/ -- /usr/bin/filebeat -c /usr/xxx/filebeat/filebeat.yml

this is my definition in my filebeat.yml for the registry

registry_file: .filebeat-registry

Can you share your full config?


        - /usr/tomcat/logs/catalina.out
      input_type: catalina
       discriminator: xxxxxx
       assembly: xxxxxx
       container: xxxxxx
       managementunit: xxxxxx
       mnemonic: xxxxxx
       division: xxxxxx
       environment: xxxxxx

      fields_under_root: true
registry_file: .filebeat-registry
    enabled: true
    hosts: ["]
    worker: 1
  level: debug
  to_files: true
    path: /usr/filebeat/
    name: filebeat-agent.log
    rotateeverybytes: 10485760

Which version of filebeat are you using? The most recent version of Filebeat (5.0.0-alpha-x) introduces a data path: As the data path can also be configured as a parameter I assume this would work better in your case.

I think the problem with the above is that all instances are creating the registry file in the same place as it is relative the executable. Can you check how many registry files you have? Alternatively use absolute paths for the registry file.

version 1.1.1 initially i gave the full path it still did not work. I have one registry and that is also names
.registry, it works fine if i start it with filebeat and not filebeat-god.



Can you add some log output from running filebeat in foreground? Just for us to confirm it's working as intended. If possible I'd use an absolute path, otherwise filebeat will try to create the registry file in current working directory (no idea which directory will be used if run as a service).

This topic was automatically closed after 21 days. New replies are no longer allowed.