Filebeat hanging with a redis output


(harry.tewkesbury@worldfirst.com) #1

EDIT: Please Ignore - PEBCAK error. Apologies. Redis endpoint wasn't correct. Sigh. Not that logging helped with that mind... no logs were written to say it wasn't accessible, even with the timeout in place as seen in the config.


Hi there,

I have a filebeat config that is refusing to talk to redis. I have used a similar config with a windows server with success.

The result is that when running "service filebeat start", the cli hangs and no logging output is generated. io usage is zero as is CPU cycles. My config follows.

   ############################# Filebeat #####################################

    filebeat:
      prospectors:
        -
          paths:
           - /var/log/syslog
    #        - /var/www/q*/logs/*.log
    #        - /var/www/q*/current/storage/logs/*.log

          input_type: log

          registry_file: /var/lib/filebeat/registry

    ############################# Output #######################################

    output:
    #  file:
    #    path: "/tmp/filebeat"
    #    filename: "filebeat"
    #    rotate_ever_kb: 1000
    #    number_of_files: 7


      redis:
        host: "harrylogstash0"
        port: 6379
        timeout: 5
        reconnect_interval: 10

    ############################ Logging #######################################

    logging:
      to_files: true
      files:
        path: /var/log/FileBeatLogs/

        name: filebeat.log
        rotateeverybytes: 10485760 # = 10MB
        keepfiles: 7

Any help would be appreciated. As you can see, when I replaced the redis with a file output, it worked fine. /usr/bin/filebeat -c /etc/filebeat/filebeat.yml -configtest also hangs.

Thanks.


(Andrew Kroh) #2

In Filebeat 5.0 we made some changes to logging to make it better out of the box. We reworked some the logging levels used by certain messages, changed the default logging level from error to info, and made the default logging output be file instead of syslog. Hopefully this will help make logging better in the future.


(system) #3

This topic was automatically closed after 21 days. New replies are no longer allowed.