Filebeat is not able to send logs to elastic

#=========================== Filebeat inputs =============================


Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • input_type: log

    Change to true to enable this input configuration.

    enabled: true

    encoding: utf-8

    Paths that should be crawled and fetched. Glob based paths.


    • c:\Users\PankajKoushik\Downloads\log-aggregation-spring-boot-elastic-stack-master\notification\logs*.log
      #- c:\programdata\elasticsearch\logs*

#============================= Filebeat modules ===============================


Glob pattern for configuration loading

path: ${path.config}/modules.d/*.yml

Set to true to enable config reloading

reload.enabled: true

Period on which files under path should be checked for changes

#reload.period: 10s

#================================ Outputs =====================================

#-------------------------- Elasticsearch output --------------------------------


#-------------------------- Elasticsearch hosts
hosts: [""]
index: "filebeat-%{+yyyy.MM.dd}"

I have this filebeat.yml

What does the corresponding Elasticsearch config look like? Is it really listening to port 8080?

Yes I am running elastic in docker

So I have exposed the port 8080

But internally I am using 9200

Can you curl Elasticsearch from the Filebeat host?


I tried ,I am able to ping

Ping does not tell you anything. Are you able to connect via curl?

Yes,I am able to curl also

Is there anything in the logs?

I am getting

INFO Non-zero metrics in the last 30s:registrar.writes=1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.