FileBeat + LogsTash port 5044

Error ERROR#011[publisher_pipeline_output]#011pipeline/output.go:154#011Failed to connect to backoff(async(tcp://192.168.10.14:5044)).
I can not connect on port 5044 with logstash! On the logstash server port 5044 is open and listening.
Question:

  1. How can I connect to 5044 ???
  2. Is it possible to do this WITHOUT using ssl?
  3. Is it possible to do this WITHOUT using Docker?
    ===Filebeat.yml===

filebeat.inputs:
- type: log
enabled: true
paths:
- /var/log/nginx/*.log
- /var/log/syslog
output.logstash:
hosts: ["192.168.100.14:5044"]
worker: 1
processors:

  • add_host_metadata: ~
  • add_cloud_metadata: ~
  • add_docker_metadata: ~
  • add_kubernetes_metadata: ~

what does you logstash config look like?

    input {
      beats {
      host => 192.168.100.14
      port => 5044
     }
    }
    filter {
    if [fileset][module] == "nginx" {
        if [fileset][name] == "access" {
    grok {
    match => { "message" => ["%{IPORHOST:[nginx][access][remote_ip]} - %{DATA:[nginx][access][user_name]} \[%{HTTPDATE:[nginx][access][time]}\] \"%{WORD:[nginx][access][method]} %{DATA:[nginx][access][url]} HTTP/%{NUMBER:[nginx][access][http_version]}\" %{NUMBER:[nginx][access][response_code]} %{NUMBER:[nginx][access][body_sent][bytes]} \"%{DATA:[nginx][access][referrer]}\" \"%{DATA:[nginx][access][agent]}\""] }
    remove_field => "message"
    }
    }
    }
    }
    output {
        beat {
      elasticsearch {
        hosts => ["http://192.168.100.14:9200"]
        index => "%{[@metadata][beat]}-%{dd.MM.+YYYY}"
        manage_template => false
    	}
    	}
    	}
========Logstash.yml=======
# ------------ Data path ------------------
path.data: /var/lib/logstash
# ------------ Metrics Settings --------------
http.host: "0.0.0.0"
# ------------ Pipeline Configuration Settings --------------
path.config: /etc/logstash/conf.d/*.conf
# ------------ Debugging Settings --------------
log.level: info
path.data: /var/log/logstash

So you're not using SSL currently and are you using docker containers for Filebeat and /or Logstash? If so, have you exposed the ports properly? Are you sure there's not firewall blocking the connection?

I don't use ssl. I don't use docker. there is no firewall. Virtual machine on ProxMox, on 1VM - elastic and logstash - port 5044 is listened to; 2VM -filebeate.