Filebeat No data has been received from this module yet

I have a container for kibana on a network named emk and mapped port of 5601 and a container for filebeat on the emk and three redis containers on emk and logstach on emk. I can ping all hosts from each other. I tried to follow the tutorial on kibana to configure redis_log (http://localhost:5601/app/kibana#/home/tutorial/redisLogs?_g=() on my machine). the problem is when I click on check_data on the previous link I get error
No data has been received from this module yet
here is my redis module file:
- module: redis
# Main logs
log:
enabled: true
slowlog:
enabled: true
var.hosts: ["redis1:6379", "redis2:6379", "redis3:6379"]
my filebeat.yml:

output.elasticsearch:
  hosts: ["elasticsearch:9200"]
setup.kibana:
  host: "kibana:5601"

and here is my filebeat log file:

2019-11-13T09:54:15.362Z	INFO	instance/beat.go:615	Beat ID: a4f98705-26b3-43e7-8ea6-b1f4915184ce
2019-11-13T09:54:15.363Z	INFO	[beat]	instance/beat.go:903	Beat info	{"system_info": {"beat": {"path": {"config": "/etc/filebeat", "data": "/var/lib/filebeat", "home": "/usr/share/filebeat", "logs": "/var/log/filebeat"}, "type": "filebeat", "uuid": "a4f98705-26b3-43e7-8ea6-b1f4915184ce"}}}
2019-11-13T09:54:15.363Z	INFO	[beat]	instance/beat.go:912	Build info	{"system_info": {"build": {"commit": "15075156388b44390301f070960fd8aeac1c9712", "libbeat": "7.4.2", "time": "2019-10-28T19:46:13.000Z", "version": "7.4.2"}}}
2019-11-13T09:54:15.363Z	INFO	[beat]	instance/beat.go:915	Go runtime info	{"system_info": {"go": {"os":"linux","arch":"amd64","max_procs":8,"version":"go1.12.9"}}}
2019-11-13T09:54:15.364Z	INFO	[beat]	instance/beat.go:919	Host info	{"system_info": {"host": {"architecture":"x86_64","boot_time":"2019-11-13T05:49:26Z","containerized":true,"name":"2c5db2c7085d","ip":["127.0.0.1/8","172.20.0.8/16"],"kernel_version":"4.15.0-69-generic","mac":["02:42:ac:14:00:08"],"os":{"family":"redhat","platform":"centos","name":"CentOS Linux","version":"7 (Core)","major":7,"minor":6,"patch":1810,"codename":"Core"},"timezone":"UTC","timezone_offset_sec":0,"id":"95d11e1c2b8f473dbfb0c68f217d6cdd"}}}
2019-11-13T09:54:15.364Z	INFO	[beat]	instance/beat.go:948	Process info	{"system_info": {"process": {"capabilities": {"inheritable":["chown","dac_override","dac_read_search","fowner","fsetid","kill","setgid","setuid","setpcap","linux_immutable","net_bind_service","net_broadcast","net_admin","net_raw","ipc_lock","ipc_owner","sys_module","sys_rawio","sys_chroot","sys_ptrace","sys_pacct","sys_admin","sys_boot","sys_nice","sys_resource","sys_time","sys_tty_config","mknod","lease","audit_write","audit_control","setfcap","mac_override","mac_admin","syslog","wake_alarm","block_suspend","audit_read"],"permitted":["chown","dac_override","dac_read_search","fowner","fsetid","kill","setgid","setuid","setpcap","linux_immutable","net_bind_service","net_broadcast","net_admin","net_raw","ipc_lock","ipc_owner","sys_module","sys_rawio","sys_chroot","sys_ptrace","sys_pacct","sys_admin","sys_boot","sys_nice","sys_resource","sys_time","sys_tty_config","mknod","lease","audit_write","audit_control","setfcap","mac_override","mac_admin","syslog","wake_alarm","block_suspend","audit_read"],"effective":["chown","dac_override","dac_read_search","fowner","sys_boot","sys_nice","sys_resource","sys_time","sys_tty_config","mknod","lease","audit_write","audit_control","setfcap","mac_override","mac_admin","syslog","wake_alarm","block_suspend","audit_read"],"ambient":null}, "cwd": "/root", "exe": "/usr/share/filebeat/bin/filebeat", "name": "filebeat", "pid": 109, "ppid": 20, "seccomp": {"mode":"disabled","no_new_privs":false}, "start_time": "2019-11-13T09:54:14.320Z"}}}
2019-11-13T09:54:15.364Z	INFO	instance/beat.go:292	Setup Beat: filebeat; Version: 7.4.2
2019-11-13T09:54:15.364Z	INFO	[index-management]	idxmgmt/std.go:178	Set output.elasticsearch.index to 'filebeat-7.4.2' as ILM is enabled.
2019-11-13T09:54:15.365Z	INFO	elasticsearch/client.go:170	Elasticsearch url: http://elasticsearch:9200
2019-11-13T09:54:15.365Z	INFO	[publisher]	pipeline/module.go:97	Beat name: 2c5db2c7085d
2019-11-13T09:54:15.366Z	INFO	elasticsearch/client.go:170	Elasticsearch url: http://elasticsearch:9200
2019-11-13T09:54:15.367Z	INFO	elasticsearch/client.go:743	Attempting to connect to Elasticsearch version 7.4.2
2019-11-13T09:54:15.447Z	INFO	[index-management]	idxmgmt/std.go:394	Set setup.template.name to '{filebeat-7.4.2 {now/d}-000001}' as ILM is enabled.
2019-11-13T09:54:15.447Z	INFO	[index-management]	idxmgmt/std.go:399	Set setup.template.pattern to 'filebeat-7.4.2-*' as ILM is enabled.
2019-11-13T09:54:15.447Z	INFO	[index-management]	idxmgmt/std.go:433	Set settings.index.lifecycle.rollover_alias in template to {filebeat-7.4.2 {now/d}-000001} as ILM is enabled.
2019-11-13T09:54:15.458Z	INFO	template/load.go:169	Existing template will be overwritten, as overwrite is enabled.
2019-11-13T09:54:15.551Z	INFO	template/load.go:108	Try loading template filebeat-7.4.2 to Elasticsearch
2019-11-13T09:54:15.624Z	INFO	template/load.go:100	template with name 'filebeat-7.4.2' loaded.
2019-11-13T09:54:15.624Z	INFO	kibana/client.go:117	Kibana url: http://kibana:5601
2019-11-13T09:54:15.760Z	INFO	kibana/client.go:117	Kibana url: http://kibana:5601
2019-11-13T09:54:18.364Z	INFO	add_cloud_metadata/add_cloud_metadata.go:87	add_cloud_metadata: hosting provider type not detected.
2019-11-13T09:55:05.010Z	INFO	instance/beat.go:777	Kibana dashboards successfully loaded.
2019-11-13T09:55:05.010Z	INFO	elasticsearch/client.go:170	Elasticsearch url: http://elasticsearch:9200
2019-11-13T09:55:05.012Z	INFO	elasticsearch/client.go:743	Attempting to connect to Elasticsearch version 7.4.2
2019-11-13T09:55:05.047Z	INFO	kibana/client.go:117	Kibana url: http://kibana:5601
2019-11-13T09:55:05.099Z	INFO	elasticsearch/client.go:170	Elasticsearch url: http://elasticsearch:9200
2019-11-13T09:55:05.100Z	INFO	elasticsearch/client.go:743	Attempting to connect to Elasticsearch version 7.4.2
2019-11-13T09:55:05.119Z	INFO	elasticsearch/client.go:170	Elasticsearch url: http://elasticsearch:9200
2019-11-13T09:55:05.120Z	INFO	elasticsearch/client.go:743	Attempting to connect to Elasticsearch version 7.4.2
2019-11-13T09:55:05.165Z	INFO	fileset/pipelines.go:134	Elasticsearch pipeline with ID 'filebeat-7.4.2-redis-log-pipeline' loaded
2019-11-13T09:55:05.185Z	INFO	fileset/pipelines.go:134	Elasticsearch pipeline with ID 'filebeat-7.4.2-redis-slowlog-pipeline' loaded
2019-11-13T09:55:05.185Z	INFO	cfgfile/reload.go:264	Loading of config files completed.
2019-11-13T09:55:05.185Z	INFO	[load]	cfgfile/list.go:118	Stopping 1 runners ...

Hi @yasharne,

I don't see any error in Filebeat logs. Did you enable the module first? Can you see any data if you go to discover page?

Hi @exekias
Yes, I have enabled it, when I type the command filebeat modules list I get this output:
Enabled:
redis