Filebeat not indexing data to elasticsearch


I use beat 6.4.0... Beats not indexing data to elastic search. filebeat.yml looks like below


Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • type: log

    Change to true to enable this input configuration.

    enabled: false

    Paths that should be crawled and fetched. Glob based paths.

    #- /var/log/*.log
    #- c:\programdata\elasticsearch\logs*

    • /home/ec2-user/json/logstash-tutorial-dataset

Output Section


Array of hosts to connect to.

#hosts: ["localhost:9200"]
hosts: [""]
filebeat.registry_file: /var/lib/filebeat/registry
#index: "filebeat-%{[beat.version]}-%{+yyyy.MM.dd}" "filebeat"
#setup.template.pattern: "filebeat-*"

Optional protocol and basic auth credentials.

#protocol: "https"
#username: "elastic"
#password: "changeme"

Please help to fix

You probably want to set enabled: true in the log input.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.