Filebeat not reading the files with names saved as numbers

My log files are named with numbers for example 45678.rdlog and the filebeat couldn't able to read it and if I re name the file to something like test.rdlog it can able to read it.

these logs are generated by rundeck and we have no control over it.

Please help us to address this issue.

Thanks in advance.

#------------------------------ Log input --------------------------------
- type: log

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
  # To fetch all ".log" files from a specific level of subdirectories
  # /var/log/*/*.log can be used.
  # For each file found under this path, a harvester is started.
  # Make sure not file is defined twice as this can lead to unexpected behaviour.
    - /var/log/*.log

You can set the log files path as *.rdlog and it should work. There should not be any restriction that the file name cannot be numbers

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.