Filebeat not sending logs in real time

Hello Team,

We have upgraded our ELK stack from 6.4 to 6.8 but we are using beats 6.4.

Before upgradation all the logs were reaching on kiabna in real time. But we upgraded our ELK from 6.4 to 6.8 and now filebeat is not sending the logs in real time on kibana.

Even we have tried with filebeat 6.8 on one machine and still logs were not reaching in real time on kibana.

Below is the configuration of my filebeat.yml file:

###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common
# options. The filebeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/filebeat/index.html

# For more available modules and options, please see the filebeat.reference.yml sample
# configuration file.

#=========================== Filebeat inputs =============================

filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.
#registry_file: /var/lib/filebeat/registry
- type: log

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
#    - /var/log/*.log
    - /var/apps/mobilock/shared/log/production.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ['^DBG']
  exclude_lines: ['^.*health.*$']
  fields_under_root: true
  fields:
    type: application_log

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ['^ERR', '^WARN']

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #exclude_files: ['.gz$']

  # Optional additional fields. These fields can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
  #  level: debug
  #  review: 1

  ### Multiline options

  # Multiline can be used for log messages spanning multiple lines. This is common
  # for Java Stack Traces or C-Line Continuation

  # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
  #multiline.pattern: ^\[

  # Defines if the pattern set under pattern should be negated or not. Default is false.
  #multiline.negate: false

  # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
  # that was (not) matched before or after or as long as a pattern is not matched based on negate.
  # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
  #multiline.match: after
  multiline.pattern: '[A-Z]{1}, \[[0-9]{4}-[0-9]{2}-[0-9]{2}'
  multiline.negate: true
  multiline.match: after
- type: log
  enabled: true
  paths: 
     - /var/log/syslog
  fields_under_root: true
  fields:
    type: syslog_logs

- type: log
  enabled: true
  paths:
     - /var/log/auth.log
  fields_under_root: true
  fields:
    type: auth_logs

- type: log
  enabled: true
  paths:
     - /var/log/nginx/access.log
#     - /var/log/nginx/error.log
  fields_under_root: true
  fields:
    type: nginx_access
#============================= Filebeat modules ===============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 3
  #index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
#  env: staging


#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here, or by using the `-setup` CLI flag or the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
#setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
#  host: "localhost:5601"

#============================= Elastic Cloud ==================================

# These settings simplify using filebeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
#output.elasticsearch:
  # Array of hosts to connect to.
#  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["xyz:5044"]
  bulk_max_size: 1024

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]
  ssl.certificate_authorities: ["/etc/pki/tls/ca.crt"]
  ssl.certificate: "/etc/pki/tls/client.crt"
  ssl.key: "/etc/pki/tls/client.key"
  ssl.key_passphrase: "xyz"

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================
# filebeat can export internal metrics to a central Elasticsearch monitoring
# cluster.  This requires xpack monitoring to be enabled in Elasticsearch.  The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#xpack.monitoring.enabled: false

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
#xpack.monitoring.elasticsearch:

I have enabled the debug level in logging and we can see that filebeat is lagging and not reading the real time logs from the log file.

message": "I, [2021-01-06T10:48:42.312825 #15659]  INFO -- : [75f1b179-dd1d-4abc-bbdb-41f6796b4a42] Completed 200 OK in 185ms (Views: 0.4ms | ActiveRecord: 95.9ms)

This is the last log which is read by filebeat but the current time on the system is Thu Jan 7 00:19:17 UTC 2021 and we have the logs on the system for same date. I am pasting the single log of current date:

I, [2021-01-07T00:20:33.024526 #15631]  INFO -- : [f42f4203-5aec-48f0-8bca-e522190c6194] update_device_last_connected :: device: 811947 : updating params : {:inactivity_email_sent_at=>nil, :inactive=>false, :last_connected_at=>Thu, 07 Jan 2021 00:20:33 UTC +00:00}

Even i have tried by sending the logs directly to elasticsaerch instead of using logstash for extra level of parsing and still same behaviour.

Can you please help me on this issue?

Its our production environement.

Thank You

Hello Team,

Can you please help me on this issue?

Thank You

Hello Team,

We are running out of ideas and this problem is still persist.

Please help me.

Thank You

Before trying to help you i might suggest to update to the last version.

I'm interested to see this issue resolved

@grumo35, Thank You for your response.

We have setup new cluster with latest version i.e 7.10 of all the stack like elasticsearch, kibana, logstash and beats.

We integrate one server with filebeat over this cluster and we get the logs in real time on kibana dashboard for this server like application logs, nginx logs , syslog and authlog.

But the issue is started when we enable the xpac seeurity feature on the cluster because we want to use the Roles and Users feature for RBAC of kibana.

Once xpac security is enabled and start the filebeat service then we can clearly see that filebeat is not shipping the logs in real time.

We used the below link to enable the security feature in elasticsaerch:

Enable security in elasticsaerch

We generate the SSL cert and internal user password according above doc.

Now i am mentioing the other changes we did in the following steps:

  1. We specify the kibana user and password in kibana.yml so kibana can connect to the elasticsaerch cluster and can fetch the data.
elasticsearch.username: "kibana"
elasticsearch.password: "xyz"

  1. We specify the user and passowrd in logstash output so it can send the data to elasticsaerch cluster. We use the elastic user and passowrd in logstash output filter. Elastic is superuser.
output {
  if [@metadata][pipeline] {
    elasticsearch {
    hosts => ["1.2..3.4:9200"]
    user => "elastic"
    password => "abc"
    manage_template => false
    index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
    pipeline => "%{[@metadata][pipeline]}"
    }
	}
else {
    elasticsearch {
    hosts => ["1.2.3.4:9200"]
    user => "elastic"
    password => "abc"
    manage_template => false
    index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
    }
  }
}
  1. There is no authentication between filebeat and logstash.

Can you please help me what is cause of filebeat lagging in sending the logs after enabling the security feature?
Do we need to enable xpac security on kibana and logsatsh as well? If yes then how or please share a doc which we can follow.

Or i am doing any mistake in this setup?

Please help me.

Thank You