Filebeat not starting as Daemonset


(Victor Renan Covalski Junes) #1

Hi,

I'm trying to deploy Filebeat to collect logs from my Kubelets using the provided example.

Although, my filebeat container is not starting and I'm getting the following error messages

May  7 15:26:22 xxx kubelet: E0507 15:26:22.781732     644 pod_workers.go:186] Error syncing pod dbd96cee-5223-11e8-ad37-000c29ea6766 ("filebeat-xwfxr_kube-system(dbd96cee-5223-11e8-ad37-000c29ea6766)"), skipping: failed to "StartContainer" for "filebeat" with RunContainerError: "failed to start container \"2def5e6ae0969b060661c23ffc0542413a738d991b890f7462c50601b2467736\": Error response from daemon: linux mounts: Path /var/lib/docker/containers is mounted on /var/lib/docker/containers but it is not a shared or slave mount."
May  7 15:26:33 xxx kubelet: E0507 15:26:33.658283     644 pod_workers.go:186] Error syncing pod dbd96cee-5223-11e8-ad37-000c29ea6766 ("filebeat-xwfxr_kube-system(dbd96cee-5223-11e8-ad37-000c29ea6766)"), skipping: failed to "StartContainer" for "filebeat" with CrashLoopBackOff: "Back-off 1m20s restarting failed container=filebeat pod=filebeat-xwfxr_kube-system(dbd96cee-5223-11e8-ad37-000c29ea6766)" ยด

I've tried setting the MountFlags option to shared, although it didn't work.

I'm using the following versions of Kubernetes and Docker on CentOS 7

docker --version
Docker version 1.13.1, build 774336d/1.13.1

kubectl version
Client Version: version.Info{Major:"1", Minor:"10", GitVersion:"v1.10.0", GitCommit:"fc32d2f3698e36b93322a3465f63a14e9f0eaead", GitTreeState:"clean", BuildDate:"2018-03-26T16:55:54Z", GoVersion:"go1.9.3", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"10", GitVersion:"v1.10.1", GitCommit:"d4ab47518836c750f9949b9e0d387f20fb92260b", GitTreeState:"clean", BuildDate:"2018-04-12T14:14:26Z", GoVersion:"go1.9.3", Compiler:"gc", Platform:"linux/amd64"}

I think I'm missing an important point or configuration here since I couldn't find any related issues on the internet.

Any help will be greatly appreciated :).


(Pier-Hugues Pellerin) #2

@Victor_Covalski I think you are running into an issue with bind propagation, I would check the official docker doc if that fixes your issues we might want to update our documentation.


(Victor Renan Covalski Junes) #4

Thanks @pierhugues.

Update:

After reading through the documentation I decided to confirm if my MountFlags option was being considered by Docker.

So I ran

findmnt -o TARGET,PROPAGATION /var/lib/docker/containers
TARGET                     PROPAGATION
/var/lib/docker/containers shared

I'm still running into the same issue. My Filebeat container image is version 6.2.4


(Victor Renan Covalski Junes) #5

Update;

It seems it is a recently found bug in CentOS 7. My kernel version matches the one in the bug report found here

I think this thread can be closed now since it is not related to Beats.


(Pier-Hugues Pellerin) #6

thanks for updating it. :slight_smile:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.