Filebeat reads file too fast

I have a problem with filebeat that it reads the file while the file is being overwritten by another process. This problem result in loading/reading some junk entries by Filebeat.
My current configuration is :

  • type: log
    enabled: true

    • /pa/vertica_backup_qa/otherscripts/orgmapload/scripts/filetoload.txt
      exclude_lines: ['^Site,Maker']

    document_type: orga-type

    scan_frequency: 3600s

path: ${path.config}/modules.d/*.yml

reload.enabled: false "sys_username_mapping"
setup.template.pattern: "sys_username_map*"

json.overwrite_keys: true

hosts: [""]

logging.level: info

Here same file "filetoload" is getting updated(overwritten) once per day at 1:00 PM and the path is on NFS. So I want that filebeat should read/load the file only if it is not being overwritten by any other process
Please suggest

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.