Filebeat service doesn't send apache logs

This is my current configuration file.

- type: log
  enabled: true
    - /var/log/apache2/*.log

  hosts: ["localhost:5044"]
  enabled: true

setup.dashboards.enabled: true
  host: "localhost:5601"

my logstash.conf file.

input {
        beats {
                port => "5044"

filter {
        grok {
                match => { "message" => "%{COMBINEDAPACHELOG}" }
        date {
                match => [ "timestamp", "dd/MMM/yyyy:HH:mm:ss Z" ]

output {
        elasticsearch {
                hosts => ["localhost:9200"]
                index => "apache"

        stdout {}


although filebeat listening 5044 port, there is nothing on elasticsearch. how can i solve?

What is showing up in the logstash console?

Also Filebeat will only send the file once if you want to send it again you need to clean out the data registry..

Also Did you know there is a built-in in module for Apache logs in Filebeat... You don't need Logstash?

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.