Filebeat stops sending logs after logrotates


(Naga D) #1

Filebeat stops sending logs after app log rotates over night.
App lognames are below --

  • virtual.access.20160111
  • virtual.access.20160112

Below is the Code SnippSet
///
filebeat:
prospectors:
-
paths:
- "/apache/qa-httpd/"
fields_under_root: true
document_type: apache
-
paths:
- "/tomcat/qa-r
"
fields_under_root: true
document_type: tomcat
shipper:
name: "test"
tags: ["testqa"]
ignore_outgoing: true
refresh_topology_freq: 10
topology_expire: 15

output:
logstash:
enabled: true
hosts: ["localhost:5044"]
timeout: 30
################Logging#################
logging:
to_files: true
to_syslog: false
files:
path: /var/log/filebeat
name: filebeat.log
keepfiles: 10
///

Any idea why its stops sending the logs after every nights rotation?


(ruflin) #2

Could you provide beat version and OS? Beats: How to report an issue

Also please post your config as "code" with 3 backticks starting / ending to make it more readable.


(Naga D) #3

@ruffin
Here is the Beats version-- filebeat version 1.0.0-rc2 (amd64)
OS -- Red Hat Enterprise Linux Server release 6.6 (Santiago)


(ruflin) #4

Could you please update to 1.0.1 to see if the issue persists? There were many bugfixes since rc2.


(system) #5