Filebeat unable to dial tcp on port logstash port 5044

I am running logstash on remote Centos 6.8 machine. While sending logs via filebeat getting error

ERROR pipeline/output.go:74 Failed to connect: dial tcp i/o timeout

Tried telnet from filebeat server:
telnet 5044
But got connection refused error.

I tried telnet on the Logstash server also, and telnet was happening.
telnet 5044
Connected to
Escape character is '^]'.

Tried netstat on logstash server:
netstat -anp | grep 5044
tcp 0 0* LISTEN 31861/java

Any idea how to troubleshoot this, am I missing anything?

192.168.x.x is a private range dedicated for use within a private network; are the two devices on the same network, and if so is there a route from one host to the other?

I typically use ping and traceroute to discover the answers to these questions.

Yeah, both the machines are in the same network, and both are able to ping each other.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.