Filebeat + Windows: Spaces in directories


(Roger Keulen) #1

I'm trying to setup filebeat on a windows machine

The dir of apache logs = C:/Program Files (x86)/EasyPHP/binaries/apache/logs/error*

The error i get is:
Exiting: Error getting config for fielset apache2/error: Error interpreting the template of the prospector: template: text:3:22: executing "text" at <.paths>: range can't iterate over C:/Program Files (x86)/EasyPHP/binaries/apache/logs/error*

Can you gave a example how to fill in a unstructered file called: "yml".


(Roger Keulen) #2

Got it....

You must put a "-" before it, beacuse that is how "linux" people write lists aperantly.

I like XML with a schema. Linux people are still living in the 50's....


(Roger Keulen) #3

Next problem. Now i need a string to tell him "no_plugins"

I already tried:

var.pipeline: no_plugins
var.pipeline: "no_plugins"
var.pipeline: 'no_plugins'

  • var.pipeline: no_plugins
    var.pipeline: [no_plugins]

Programming in notepad is super cool..... and high tech !


(Noémi Ványi) #4

Could you share the whole file you are trying to edit? Please format it using the </> button in the editors toolbar.


(Roger Keulen) #5

No, that is not possible, I get a error: "Body is limited to 7000 characters; you entered 37965."
I tried to remove all the "help" you need to give people, but i can have made mistakes.

filebeat.modules:

  • module: apache2

    access:
    enabled: true

    var.pipeline: no_plugins
    var.paths:
    - C:/test/log/*

output.elasticsearch:
hosts: ["localhost:9200"]
username: "elastic"
password: "changeme"


(Noémi Ványi) #6

Unfortunately, the support of no_plugins option was removed. I have found documentation which includes it, but it is not right. We will update the docs.

So if you want to use apache2 you have to install the plugins.


(Roger Keulen) #7

Thanx !

(Not having the plugin isn't the problem, as long i know the way i have to
fill this in is correctly.)


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.