Filebeat.yml config file permissions owner


I get an error when I start Filebeat about the permissions of the filebeat.yml file

error loading config file: config file ("/etc/filebeat/filebeat.yml") can only be writable by the owner but the permissions are "-rwxrwxrwx"

I cannot change the permissions of the file because I am not the administrator of the machine and they have given me permissions only to my user and group to be able to modify the configuration file (I am the administrator of the tool)

I have seen in other posts that it is possible to disable the check with the --stricts.perms=false parameter, but I don't see how to execute filebeat with this parameter, I have tried with filebeat -e --strict.perms=false but it doesn't work, how? I can do it?

Is there a way to change the configuration so that whenever the service starts it has this parameter by default?

Thanks greetings.

Maybe try to change owner of filebeat by "chown username: /etc/filebeat.filebeat.yml"


I have tried to change the owner and it was still the same until I removed the permissions to groups and others assigned before.

At that moment when only the owner has permissions, it has already worked.

However, now it throws another error indicating that it does not have permission to create the /var/lib/filebeat directory.

Exiting: error setting default paths: Failed to create data path /var/lib/filebeat: mkdir /var/lib/filebeat: permission denied

Do I have to change the permissions of any additional file? Only root can own filebeat.yml?

Thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.