Fine tune APM server settings on the hosted solution (cloud.elastic.co)

Kibana version:
6.6.2

Elasticsearch version:
6.6.2

APM Server version:
6.6.2

APM Agent language and version:
Ruby: 2.6.1

Original install method (e.g. download page, yum, deb, from source, etc.) and version:

APM and Elasticsearch are under the managed offering (cloud.elastic.co), we chose GCP for the underlying hosting.

Fresh install or upgraded from other version?

Fresh install

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Nothing special

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

How can we change the APM server settings when installed through the cloud.elastic.co hosted solution ?

To get into the details:

We have bursts of heavy requests comming to our ruby servers. To handle them correctly we increased by 2 the number of APM workers, but now the server is responding with a "queue is full" error.
Full error message:
'[ElasticAPM] APM Server responded with an error: "queue is full"'

The solution that seems the most fitting would be to increase the server's queue capacity (queue.mem.events setting) as described here:

Or eventualy increase "output.Elasticsearch.bulk_max_size" as described in this thread:

Looking through the documentation I couldn't figure where these parameters can be changed when the install is done through the hosted solution.
Is there a way to apply custom settings ?

Cheers

Hello,

You are right, currently there is no way to change those settings on Cloud sorry for that.
We are currently working to make them available so you can change them, stay tuned!

Juan

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.