Ganglia into logstash

I know this isn't the first issue with ganglia, but I've dug through all the other forum posts on it and it's not getting anywhere. I've established through the command "tcpdump -i any udp" that I'm getting the UDP ganlia packets on port 8649, so there isn't an issue with ganglia or the network getting the packets to the logstash server.

My pipeline is as follows (right now I'm trying to troubleshoot ganglia, so that's the only one I'm dealing with):

input {
        ganglia {
                port => 8649

output {
        stdout {
                codec => rubydebug

I've checked my listening ports, and I had an issue with it only listening on ipv6 (what's up with that?), which was solved through this post. So now, I'm listening on the right ports, getting the right packets to the server, but getting nothing through logstash. Any ideas?

1 Like

I tried getting the Ganglia input plugin working a month or so ago and couldn't get it working for the life of me. I even got to the point that I was monitoring packets and knew that proper Ganglia data was going to the machine running the Logstash Ganglia plugin, but nothing was showing up in Logstash.

Spooky stuff, I hope someone can fix it. It's a community-supported plugin so it seems like it's not priority to get it fixed.

There was an update the Logstash Ganglia Github about 20 days ago, maybe that fixed it?

That looks like it did indeed fix it. I just started testing again, and lo and behold, the new plugin is giving me lots of packets. I'm not getting any metrics out of it yet, but I'm satisfied that I'm getting something.