Getting Error-Cannot delete files/directories outside the current working directory when i wants to generate visualization report in pdf

above is the Kibana config file and below is the ElasticSearch config file.

bootstrap.memory_lock: false
cluster.name: elasticsearch
http.port: 9000
network.host: 10.88.132.75
node.data: true
node.ingest: true
node.master: true
node.max_local_storage_nodes: 1
node.name: LCCWIPAP4527
path.data: D:\ElasticSearch-6.4.0\Data
path.logs: D:\ElasticSearch-6.4.0\Logs
transport.tcp.port: 9500
discovery.seed_hosts: [10.88.132.75]
discovery.type: single-node
xpack.license.self_generated.type: basic
xpack.security.enabled: true
xpack.security.authc.realms:
ldap:
ldap1:
order: 0
enabled: true
url: "ldaps://nalinadcpvip.alight.com:636"
timeout.tcp_read: 60s
timeout.tcp_connect: 60s
timeout.ldap_search: 60s
ssl:
certificate_authorities: ["LDAP.cer"]
ssl.verification_mode: certificate
user_dn_templates:
- "cn={0},OU=Functional Accounts,OU=Users and Groups,DC=hewitt,DC=com"
- "cn={0},OU=Associate Accounts,OU=Users and Groups,DC=hewitt,DC=com"
group_search:
base_dn: "OU=Associate Accounts,OU=Users and Groups,DC=hewitt,DC=com"
unmapped_groups_as_roles: false
native:
native1:
order: 1
enabled: true

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

Elastic Search config file is sharing

<bootstrap.memory_lock: false>
<cluster.name: elasticsearch>
<http.port: 9000>
<network.host: 10.88.132.75>
<node.data: true>
<node.ingest: true>
<node.master: true>
<node.max_local_storage_nodes: 1 >
<node.name: LCCWIPAP4527>
<path.data: D:\ElasticSearch-6.4.0\Data >
<path.logs: D:\ElasticSearch-6.4.0\Logs>
<transport.tcp.port: 9500>
<discovery.seed_hosts: [10.88.132.75] >
<discovery.type: single-node>
<xpack.license.self_generated.type: basic>
<xpack.security.enabled: true>
<
xpack.security.authc.realms:
<ldap:
<ldap1:
order: 0
enabled: true
url: "ldaps://nalinadcpvip.alight.com:636"
timeout.tcp_read: 60s
timeout.tcp_connect: 60s
timeout.ldap_search: 60s
<ssl:
certificate_authorities: ["LDAP.cer"] >
ssl.verification_mode: certificate
<user_dn_templates:
- "cn={0},OU=Functional Accounts,OU=Users and Groups,DC=hewitt,DC=com"
- "cn={0},OU=Associate Accounts,OU=Users and Groups,DC=hewitt,DC=com" >
<group_search:
base_dn: "OU=Associate Accounts,OU=Users and Groups,DC=hewitt,DC=com" >
unmapped_groups_as_roles: false > >
<native:
< native1:
order: 1
enabled: true > >

is it ok?

I already shared Elastic Search Config file on yesterday and now i am going to share Kibana config file-

<# Kibana is served by a back end server. This setting specifies the port to use.>
<server.port: 5000

<

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.>

<# The default is 'localhost', which usually means remote machines will not be able to connect.>
<# To allow connections from remote users, set this parameter to a non-loopback address.>
<server.host: "0.0.0.0"

<

Enables you to specify a path to mount Kibana at if you are running behind a proxy.>

<# Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath>
<# from requests it receives, and to prevent a deprecation warning at startup.>
<# This setting cannot end in a slash.>
<#server.basePath: ""

<

Specifies whether Kibana should rewrite requests that are prefixed with>

<# server.basePath or require that they are rewritten by your reverse proxy.>
<# This setting was effectively always false before Kibana 6.3 and will>
<# default to true starting in Kibana 7.0.>
<#server.rewriteBasePath: false>

<# The maximum payload size in bytes for incoming server requests.>
<#server.maxPayloadBytes: 1048576>

<# The Kibana server's name. This is used for display purposes.>
<server.name: "LCCWIPAP4527">

<# The URLs of the Elasticsearch instances to use for all your queries.>
<elasticsearch.hosts: ["http://lccwipap4527:9000"]>

<# When this setting's value is true Kibana uses the hostname specified in the server.host>
<# setting. When the value of this setting is false, Kibana uses the hostname of the host>
<# that connects to this Kibana instance.>
<#elasticsearch.preserveHost: true>

<# Kibana uses an index in Elasticsearch to store saved searches, visualizations and>
<# dashboards. Kibana creates a new index if the index doesn't already exist.>
<kibana.index: ".kibana">

<# The default application to load.>
<#kibana.defaultAppId: "home">

<# If your Elasticsearch is protected with basic authentication, these settings provide>
<# the username and password that the Kibana server uses to perform maintenance on the Kibana>
<# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which>
<# is proxied through the Kibana server.>
<elasticsearch.username: ""
elasticsearch.password: "
**">

<xpack.reporting.enabled: true
xpack.reporting.encryptionKey: "**************"
#xpack.reporting.kibanaServer: ["http://lccwipap4527:5000"]
#xpackReporting:customPdfLogo
#xpack.reporting.index: ".reporting-
"
#xpack.reporting.kibanaServer.protocol: http
#xpack.reporting.kibanaServer.hostname: ["lccwipap4527:5000"]

xpack.reporting.queue.timeout: 600000
#xpack.reporting.capture.browser.type: chromium
#xpack.reporting.capture.browser.chromium.disableSandbox: false
xpack.reporting.index: ".reporting"
#bin/kibana --force
#xpack.reporting.capture.browser.chromium.proxy.bypass: "*.elastic.co"
#xpack.reporting.capture.browser.chromium.proxy.enabled: true
#xpack.reporting.capture.browser.chromium.proxy.server: false
#xpack.reporting.capture.networkPolicy.enabled: true
#xpack.reporting.roles.enabled: false
xpack.reporting.capture.browser.chromium.disableSandbox: true

#xpack.reporting.roles.enabled: true
#xpack.reporting.roles.allow: ["reporting_user"]>

<# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.>
<# These settings enable SSL for outgoing requests from the Kibana server to the browser.>
<#server.ssl.enabled: false>
<#server.ssl.certificate: /path/to/your/server.crt>
<#server.ssl.key: /path/to/your/server.key>

<# Optional settings that provide the paths to the PEM-format SSL certificate and key files.>
<# These files are used to verify the identity of Kibana to Elasticsearch and are required when>
<# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.>
<#elasticsearch.ssl.certificate: /path/to/your/client.crt>
<#elasticsearch.ssl.key: /path/to/your/client.key>

<# Optional setting that enables you to specify a path to the PEM file for the certificate>
<# authority for your Elasticsearch instance.>
<#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]>

<# To disregard the validity of SSL certificates, change this setting's value to 'none'.>
<#elasticsearch.ssl.verificationMode: full>

<# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

the elasticsearch.requestTimeout setting.>

<#elasticsearch.pingTimeout: 1500>

<# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

must be a positive integer.>

<elasticsearch.requestTimeout: 90000>

<# List of Kibana client-side headers to send to Elasticsearch. To send no client-side

headers, set this value to (an empty list).>

<#elasticsearch.requestHeadersWhitelist: [ authorization ]>

<# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.>

<#elasticsearch.customHeaders: {}>

<# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.>
<#elasticsearch.shardTimeout: 30000>

<# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.>
<#elasticsearch.startupTimeout: 5000>

<# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.>
<elasticsearch.logQueries: true>

<# Specifies the path where Kibana creates the process ID file.>
<#pid.file: /var/run/kibana.pid>

<# Enables you specify a file where Kibana stores log output.>
<logging.dest: "D:/ElasticSearch-6.4.0/kibana-7.6.1-windows-x86_64/logs/kibana.log">
<# Set the value of this setting to true to suppress all logging output.>
<#logging.silent: false>

<# Set the value of this setting to true to suppress all logging output other than error messages.>
<logging.quiet: true>

<# Set the value of this setting to true to log all events, including system usage information

and all requests.>

<logging.verbose: false>

<# Set the interval in milliseconds to sample system and process performance

metrics. Minimum is 100ms. Defaults to 5000.>

<#ops.interval: 5000>

<# Specifies locale to be used for all localizable strings, dates and number formats.

Supported languages are the following: English - en , by default , Chinese - zh-CN .>

<#i18n.locale: "en">

Please resolve my issue and let me know you want to know anything from my side.

Regards,
Syed

can i get any updates on this?

Regards,
Syed

Can i get any updates on this?

Regards,
Syed

Unfortunately your posts are extremely hard to read without the proper formatting. It'd be appreciated if you could please edit them and format them as previously asked.

As you said i used < in starting of line and this > to end of every line.
is there any other way to post a question?

Regards,
Syed

This is what I said;

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

I would edit your posts, but you have literally put < and > on each line and that's a bit messy sorry.