Getting error while executing logstash conf file


(Ashok Gandla) #1

Hi Team,
Getting folloowing error while executing logstash conf file.
←**[31mGot error to send bulk of actions: blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];[SERVICE_UNAVAILABLE/2/no master]; {:level=>:error}←[0m**
←[33mFailed to flush outgoing items {:outgoing_count=>54, :exception=>org.elasticsearch.cluster.block.ClusterBlockException: blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized]

Can you please help me?


(Ashok Gandla) #2

This is my conf file.
input {
file {
path => "D:/Log/log1.txt"
type => "core2"
start_position => "beginning"
}
}
filter {
csv {
columns => ["TYPE","TIMESTAMP", "MESSAGE", "APPNAME"]
separator => ","
}
}

output {
elasticsearch {
action => "index"
host => "localhost"
index => "logstash-%{+YYYY.MM.dd}"
workers => 1
}
stdout {
codec => rubydebug
}
}


(Magnus Bäck) #3

Is Elasticsearch running? Is it healthy (visit http://localhost:9200/_cluster/health)? Anything interesting in its logs?


(Ashok Gandla) #4

Yes Elasticsearch is running and it is healthy.
Getting following info when i run above command.
{"cluster_name":"myelasticsearch","status":"yellow","timed_out":false,"number_of_nodes":1,"number_of_data_nodes":1,"active_primary_shards":44,"active_shards":44,"relocating_shards":0,"initializing_shards":0,"unassigned_shards":44,"number_of_pending_tasks":0,"number_of_in_flight_fetch":0}


(Magnus Bäck) #5

You have renamed your cluster to "myelasticsearch" but you haven't configured Logstash to connect to that cluster. Adjust the cluster parameter of your elasitcsearch output accordingly.


(Ashok Gandla) #6

Thank you magnusbaeck
It is working fine now :smile:


(system) #7