Has anyone tried to compile beats for Raspberry Pi (ARM) yet?


(Kai5263499) #1

When I tried to build beats from source I get the following:

make -C libbeat testsuite || exit 1; make -C packetbeat testsuite || exit 1; make -C topbeat testsuite || exit 1; make -C filebeat testsuite || exit 1; make -C winlogbeat testsuite || exit 1;
make[1]: Entering directory '/root/beats/libbeat'
# Setups environment if TEST_ENVIRONMENT is set to true
if [ true = true ]; then \
 make integration-tests-environment; \
else \
make integration-tests; \
fi
make[2]: Entering directory '/root/beats/libbeat'
make prepare-tests
make[3]: Entering directory '/root/beats/libbeat'
mkdir -p build/coverage
# coverage tools
go get golang.org/x/tools/cmd/cover
# golang.org/x/tools/cover
/usr/lib/go/src/pkg/golang.org/x/tools/cover/profile.go:55: undefined: bufio.NewScanner
scripts/Makefile:79: recipe for target 'prepare-tests' failed
make[3]: *** [prepare-tests] Error 2
make[3]: Leaving directory '/root/beats/libbeat'
scripts/Makefile:100: recipe for target 'integration-tests-environment' failed
make[2]: *** [integration-tests-environment] Error 2
make[2]: Leaving directory '/root/beats/libbeat'
scripts/Makefile:133: recipe for target 'testsuite' failed
make[1]: *** [testsuite] Error 2
make[1]: Leaving directory '/root/beats/libbeat'
Makefile:8: recipe for target 'testsuite' failed
make: *** [testsuite] Error 1

(Tudor Golubenco) #2

Topbeat and Filebeat have been reported to work on RPi. Packetbeat is more complex because it uses CGO. Compiling should be pretty easy with make crosscompile. We also produce "nightlies" with all platforms including ARM here. Probably easiest is to try one of those binaries.


(Steffen Siering) #3

interestingly it fails when building a test dependency (symbol from stdlib is missing?).

you can try e.g.:

$ cd topbeat
$ GO15VENDOREXPERIMENT=1 go build

Have setup a proper go dev-environment?


(system) #4