Heart beat 7.4 https post request

Hi Everyone,

I am trying to configure https POST URL in metric beat. Goal is to monitor api via uptime. When i test the url from post man it works perfectly but i configure same in yaml files in heartbeat it always says down. Please help me on this

- type: http
  name: testing
  enabled: true
  schedule: '@every 5s' # every 5 seconds from start of beat
  urls: ["https://xxxxxxxxxxxxxxxxxxx"]
  ipv4: true
  ipv6: true
  mode: any
  #Request settings:
    method: "POST"
        'Content-Type': 'application/json'
        'customerheader': '2aeumyabe3i9ir4ii0i'
    body: ' {"name":"abc"}'
      status: 200

Can you share the exact response/error that you get?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.