Heartbeat activemq monitor without error in activemq.log

Hi,

We're monitoring the uptime of our activemq servers (specificly the openwire port our queue is using). The problem is, with the below tcp monitor, it leaves behind some ugly logging in the activemq log. i wonder if it is possible to configure heartbeat in such a way, that it plays more nice with activemq ?

heartbeat activemq tcp monitor :

- type: tcp
  id: activemq-openwire-prd
  name: ActiveMQ OpenWire prd
  enabled: true
  schedule: '@every 30s'
  hosts: ["amqserver1:61616", "amqserver2:61616" ]
  ipv4: true
  ipv6: false
  mode: any

activemq.log:

Transport Connection to: tcp://xx.yy.zz.aaa:38432 failed: java.io.EOFException | org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ Transport: tcp:///ss.yy.zz.aa:38432@61616

No one? What about maybe building a custom monitor for this ?

Apologies for the late reply here. We probably won't make a dedicated check for activemq. Have you tried sending the correct header bytes from heartbeat?

What headers do you mean? Can i also specify headers on a tcp monitor ?

It's a bit hacky, but you can send whatever bytes you like as a header, and check the response in TCP. https://www.elastic.co/guide/en/beats/heartbeat/current/monitor-tcp-options.html#monitor-tcp-check

We will likely offer a way to script custom checks with javascript as part of synthetics in the future, stay tuned for more there as the repo isn't public yet. We announced the browser based part during elasticon, but we'll probably add API journey support in the future.