Heartbeat with Domain name target is not working

Hi All,

I have done a simple test with heartbeat to monitor the up/down of host, however, it is found that if I use IP, it works normal, however, once I change to use domain name, it doesn't work (attached).

Do I miss something? Thanks!

Kenneth

Hi Kenneth,

You should be able to provide a hostname, so this suggests that the DNS resolution may be failing (and it appears that www.cisco.com is responding to ICMP).

From the host where you are running Heartbeat, is DNS resolution working? You could try running ping www.cisco.com on the host to see if it can resolve the DNS name successfully.

Hi Paul,

DNS is working correctly, i can ping the domain in the terminal.

Thanks!

Rgds,
Kenneth

Hi Kenneth,

Just to clarify, is this still not working for you in Hearbeat?

Can you include the relevant configuration from your heartbeat.yml file please? Also, is the monitor down all of the time? Have you tried any other host names (for other services that are definitely responding to icmp), do they also fail?

Hi Paul,

Finally sort out the problem. It is due to the configuration of below, inside icmp.yml:

Configure IP protocol types to ping on if hostnames are configured.

Ping all resolvable IPs if mode is all, or only one IP if mode is any.

ipv4: true
ipv6: true
mode: any

If changing ipv6: true to false. it works without problem. I think the above configuration may make heartbeat to use ipv6 as the target.

Yes, that's right, unfortunately there's no great way to work around that issue with IPv6