His Beat requires the default distribution of Elasticsearch. Please install the default distribution of Elasticsearch from elastic.co, or install the oss-only distribution of beats]

Hi, I have installed metricbeat 6.8.2 and I have elasticsearch 6.2.4 , when try to setup metricbeat I get this:

Exiting: Couldn't connect to any of the configured Elasticsearch hosts. Errors: [Error connection to Elasticsearch http://localhost:9200: Connection marked as failed because the onConnect callback failed: This Beat requires the default distribution of Elasticsearch. Please install the default distribution of Elasticsearch from elastic.co, or install the oss-only distribution of beats]

Should I upgrade the elasticsearch? I prefer not to.

I am having similar issue, can someone help. I am new to this .

It looks like you have differing distributions of Elasticsearch and Metricbeat installed. I'm guessing you installed the OSS version of Elasticsearch, but not the OSS version of metricbeat. The "Default" version that the error message is referencing is the version that has non-open source components bundled in. This is usually the version you get when you download Metricbeat or Elasticsearch from our website.

6.2.4 is quite old, I would recommend upgrading to a newer default release.