How can I increase # of workers of rabbitmq output on the logstash 5.1.1?


(Kido Kim) #1

I am using logstash 5.1.1 for sending events to the rabbitmq.

I am trying to make multiple connections from logstash to rabbitmq for performance.
When I use logstash 2.X, worker configuration at the config file works well.
But after upgrading to 5.1.1, it does not work.
An error message told me that "You are using a plugin that doesn't support workers but have set the workers value explicitly! This plugin uses the legacy and doesn't need this option".

I read the 'A History of Logstash Output Workers' and tried to set 'pipeline.workers' and 'pipeline.output.workers'.
But it didn't work.

Is there any way to enable worker setting of rabbitmq output at logstash 5.1.1?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.