How to change the top left header logo in kibana 7.9.2

There is a chance you've accidentally made a syntax error while editing or something, take a look at the browser console and check if there are any errors there. If yes, then try to revert core.entry.js and try to change it again.

@azasypkin Its running again I have set the property to
but the logo is not changing in the header

It should be iconType:"", the value of iconType should be a string, not an object. The only change is "logoElastic" to "" the rest should stay the same.


I think you're confused by this. This is from one of my previous posts, such format only works when you edit source code/JSX, but you're editing compiled JavaScript, so the format should be iconType:""

@azasypkin tried it mate did not work :frowning:

I am out of ideas to be honest. If you edited the right file, the right place in this file and regenerated gz/br files then it should work, like it works for the login page. I can share my edited file tomorrow so that you can compare.

@azasypkin Thank you so much mate, really thanks for your effort, patience , time & dedication. You have helped me and have been patient with me throughout you even cleared some of my concepts in the process.

@azasypkin, I still don't give up. Like I said before, I successfully changed the following components:

  • Loading logo
  • Loading text
  • Favicon
  • Tab tex

Now I am trying to change the Login logo, and I am very excited, because for the very first time someone mentioned the compressed versions of the files. Of course. This is why, when I edited the files, even after restarting Kibana, I didn't see any changes and it seemed that the new code was being ignored. This time I modified both, the .js and the .gz file. Still did not see the result I was expecting, but at least something happened. I got a redundancy error, but perhaps I introduced errors in the code. I can confirm that the remote image works, but I am trying to use a base64 image instead of a remote image.

Can you help me a little bit more and let me know which of the following options is correct?:

  • "img", {src:'data:image/png;base64,iVBORw0K ... '}
  • url('data:image/png;base64,iVBORw0KGgo...')
  • "data:image/png;base64,iVBORw0K ..."?

Thank you

I am very close to my goal. Now I can upload my custom images with format like "data:image/png;base64,iVBORw0K ...", but image appears too small, it does not matter if I change the size in the source and recompile the base64 image. Is there way to increase the size to make it bigger? The default for that field is xxl, which is very small. I tried original, but I may have to reduce my image, because it went out from the right place were it should stay.

Have you tried SVGs (data:image/svg+xml;base64, compressed files contain a bunch of them as well)? The components we use are optimized to work with SVGs.

Also once you figure this out, can you share your modified files with @witcher (just to do a diff and see where the difference between your and their changes)?

You can also take a look at mine (uses SVG-data URIs for login logo and top header, source and compressed versions, but please just use it for diff, never ever run anything that a random person on the internet shares with you).

@azasypkin tried it mate did not work

Make sure you clear browser cache, because it's supposed to cache assets pretty aggressively. E.g. if you refresh page with browser dev tools open usually it doesn't respect cache or depending on the browser you may have to turn that option on.


@azasypkin I did change the core.entry.js file set the property to this just as it was in your changed files.

then I used this command to generate the zip file and the br file note that this command worked with the login page.
npx gzip-cli ..kibana-7.9.2-windows-x86_64\src\core\target\public\core.entry.js -o ..kibana-7.9.2-windows-x86_64\src\core\target\public --extension=gz --extension=br

I always clear the cache after every change I make.

I literally don't have a clue about where I am going wrong.

Hmm, do you see any difference between your core.entry.js and mine? Also check in network tab the actual content of the file that server returns to you, e.g. in my case it's http://localhost:5601/33984/bundles/core/core.entry.js.

Also if you temporarily remove .gz and .br files Kibana should serve you original non-compressed JS file - just to reduce a number of "variables" while you're debugging.

@azasypkin I did check the URL it's the same in my case

but for some reason this property is same in here it has not changed.


That's weird and I'm wondering if your Kibana is running from a different place or something.

@azasypkin I don't think so because the login page is changed .

@azasypkin no it is not i installed kibana again too the login page although does update the logo however the header does not change and in the URL



and not the svg image :frowning:

Hi @azasypkin and @witcher,

I have created and shared a guide, showing the steps for customizing the Kibana UI components, that I have been able to apply thus far. I was able to customize the Login logo just the way I was looking for. Now I will deal with the top left header logo.


@ManuelF Wow thanks.

quick question
how do you put the svg because in my case the svg file is big which causes a recursive error?

and how to put text below "Welcome toElastic"?

Well, I haven't try with SVG files, but perhaps what you need to do is to reduce the size of the source image file. This will generate a smaller SVG file.

I also had the recursive error, but I was generating a base64 file from an original image that was 721x689px. I recommend to use a source image with size between 90px and 100x, but can try a different size. Just try to reduce the source image.

And for the text do the following:

  • Open file
    $ sudo nano /usr/share/kibana/x-pack/plugins/security/target/public/4.plugin.js

  • Search for the welcome text and replace it with your own
    {id:"",defaultMessage:"Welcome to Elastic"} Result:

  • Save changes to JavaScript file and generate the compressed files. Update files permissions. Then restart Kibana.
    $ npx gzip-cli /usr/share/kibana/x-pack/plugins/security/target/public/4.plugin.js -e=gz -e=br

    $ sudo chmod 664 /usr/share/kibana/x-pack/plugins/security/target/public/*.*

    $ sudo systemctl restart kibana

@ManuelF I will try reducing the source file.

what I am saying is i want to add text below the "Welcome to Elastic" statement