How to configure spacesid for multiple spaces in beats


(Peter) #1

Hello I am wondering how to configure spacesid in the beats config files for supporting multiple spaces. I have tried with beatsid: ['Default', 'test', 'test2'] but it's not working because it's requiring a string instead of an array.

Regards,
Peter


(Noémi Ványi) #2

Beats is only able to load dashboards into one space at a time. I suggest you try to load dashboards which belong to a common Kibana space. Then load the next few dashboards to a different space after changing it in the config.


(Peter) #3

That is what I was doing, Was hoping to be able to do all at once. Not doing repetative tasks. I would however add it as a command line option.


(Noémi Ványi) #4

Unfortunately, there is no other way. You can open an enhancement request on Github: https://github.com/elastic/beats/issues/new?template=feature-request.md


(Peter) #5

Thank you for your quick reply