How to get integer field with comma-seperator to add_field

Hello Developer, I have some issue for ask you all
I tried to get field
This is the results

At add_field

         add_field => { 
"linenrMeassage" => "%{fact_or_dim}: %{linenr} rows loaded" }  

This is the results

at lineMessage I want %{linenr} with comma-seperator

PS. I tried to do this result but it's not working and I also
convert => {"linenr" => "integer"}
It's not working too

Help me please


The [linenr] field is an integer. The comma is being added in the presentation layer by kibana. If you want to format the number with commas I think you will need to use a ruby filter.

1 Like

Thank you for replying me @Badger .
I've tried your solution but It's not working.

Could you tell me what I should to do?


You need more complicated ruby code than that. See here for example.

1 Like

Thank you @Badger
I will try it :smile: .

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.